[XeTeX] Missing output from xelatex

Jan Eden lists at janeden.org
Thu Dec 2 16:41:39 CET 2004

Jonathan Kew wrote on 02.12.2004:

>On 2 Dec 2004, at 3:08 pm, Jan Eden wrote:
>>Hi Jon,
>>one more question, just out of curiosity:
>>xelatex does find the fonts installed in my ~/Fonts even if it is
>>executed by the www user. Shouldn't it only find the fonts in 
>>/Library/Fonts or System/Fonts?
>That does seem odd; I'd have expected only the fonts in "global"
>locations to be available. But I haven't experimented with this
>What happens if you're not logged in to the machine at all when the
>CGI script is accessed? Are your fonts found then, or not? I wonder
>if "personal" fonts get globally activated when you log in. (What
>about if you create a new user, leave your normal user logged in and
>switch to the new user with Fast User Switching? Does the new user
>see your fonts?)

It seemed odd to me, too. I created a new test user and accessed my CGI via the local webserver after switching to that user - same result, it just works. I can confirm that the font used for the letter (Adobe Caslon Pro) is not present in any Font directory other than /Users/jan/Library/Fonts.

I have not yet tried to log out and do the same thing again, but I will.

- Jan
Hanlon's Razor: Never attribute to malice that which can be adequately explained by stupidity.

More information about the XeTeX mailing list