[Tugindia] Error while previewing.

David Kastrup tugindia@tug.org
14 Dec 2002 17:31:10 +0100

"Baburaj A. Puthenveettil" <apbabu@mecheng.iisc.ernet.in> writes:

> Dear Kastrup,
> 	Sorry to trouble you again.

I don't know how often I have to tell you to follow the bug reporting
instructions and mail to preview-latex-bugs@lists.sourceforge.net.  I
apologize to the list members of TUG India which must by now get tired
of this bug hunting sessions and copy this post to the bug list.

> 	I could fix the link problem. Finally I had to rely on ln
> command from of linux using msys. But there seems to be some trouble
> with my TeXMF directory? Some files missing?
> I ran configure with the following option m
>  configure 
> --with-xemacs="c:/XEmacs/XEmacs-21.4.10/i586-pc-win32/xemacs.exe" -
> -with-texmf="d:/MiKTex/Local TeXMF"

File names with spaces in them are asking for trouble.  I don't know
whether our configuration and installation scripts are as bomb-proof
as such paths demand.  But I would like them to be, so please do not
change this until we have worked out whether this may also be causing

> My texmf directory is as shown in the command line option of
> configure(above)

Had you followed installation instructions or taken a look at the
output of ./configure --help, you would have noticed that the option
is called --with-texmf-dir.

> checking for gs... ./gs
> checking for latex... /d/MiKTeX/miktex/bin/latex
> checking if LaTeX is installed 8-bit clean... yes
> checking for tex... /d/MiKTeX/miktex/bin/tex
> checking for texhash... no
> checking for mktexlsr... no
> checking for MakeTeXls-R... no
> checking for makeinfo... makeinfo
> checking for docstrip directory configuration... no
> checking for TDS-compliant directory... ./configure: kpsepath: command not 
> found
> no
> checking for TeX directory hierarchy... ./configure: kpsepath: command not 
> found
> no
> checking for TeX input directory... ./configure: kpsepath: command not 
> found
> no
> configure: error: Cannot find the texmf directory!  Please use 
> --with-texmf=dir to specify where the preview tex files        go

And this error message, I am afraid, is wrong about the option name.
Installation instructions, other documentation and usage info all have
the proper name, and you found the one location where it is still
spelled wrong.  Fixed in next release.

> There doesnt seem to be any program by name texhash and the other titles 
> above in ..miktex/bin. Is this where these files should be? Is it 
> that my MiKTeX installation is not complete?   

There must be some way to "refresh the file name database".  If you
tell us what it is, we might put it into future configure scripts.  If
you do this update yourself, things should work out, however, once you
use the correct option for specifying the texmf directory (in that
case, kpsepath should not get called, I think).

David Kastrup, Kriemhildstr. 15, 44793 Bochum