[tlbuild] new clisp/libffcall/libsigsegv for testing

Mojca Miklavec mojca.miklavec.lists at gmail.com
Wed Apr 5 15:12:53 CEST 2017


I optimistically tried to cross-compile on Mac OS X, but libffcal
fails to detect the proper architecture and libsigsegv's "make check"
fails. I'll try to see if I can trick the compiler to avoid having to
go to a different machine with different architecture just for the
sake of compiling clisp (the rest of TL works just fine this way).

cd avcall && make all
/usr/bin/gcc -E `if test true = true; then echo '-DASM_UNDERSCORE';
fi` -I/path/to/libffcall-1.13-20170225/avcall/../common - <
/path/to/libffcall-1.13-20170225/avcall/avcall-x86_64-macro.S | grep
-v '^ *#line' | grep -v '^#' | sed -e 's,% ,%,g' -e 's,\. ,.,g' -e
's,@ ,@,g' -e 's,//.*$,,' -e 's/##//g' > avcall-x86_64.s
<stdin>:7:1: error: pasting "__builtin_avcall" and ":" does not give a
valid preprocessing token
/bin/sh ./libtool --mode=compile /usr/bin/gcc -x none -c avcall-x86_64.s
libtool: compile:  /usr/bin/gcc -x none -c avcall-x86_64.s -o avcall-x86_64.o
rm -f avcall.lo avcall.o
ln avcall-x86_64.lo avcall.lo
if test -f avcall-x86_64.o; then ln avcall-x86_64.o avcall.o; fi
/bin/sh ./libtool --mode=compile /usr/bin/gcc
-I/path/to/libffcall-1.13-20170225/avcall/../common  -arch ppc
-isysroot /Developer/SDKs/MacOSX10.5.sdk -mmacosx-version-min=10.5 -c
libtool: compile:  /usr/bin/gcc
-I/path/to/libffcall-1.13-20170225/avcall/../common -arch ppc
-isysroot /Developer/SDKs/MacOSX10.5.sdk -mmacosx-version-min=10.5 -c
/path/to/libffcall-1.13-20170225/avcall/avcall-structcpy.c -o
/bin/sh ./libtool --mode=link /usr/bin/gcc -o libavcall.la -rpath
/path/to/clisp-2.49.50-inst-ppc/lib avcall.lo avcall-structcpy.lo
-arch ppc -L/Developer/SDKs/MacOSX10.5.sdk/usr/lib -isysroot
/Developer/SDKs/MacOSX10.5.sdk -mmacosx-version-min=10.5
libtool: link: ar cru .libs/libavcall.a  avcall-x86_64.o avcall-structcpy.o
/opt/local/bin/ranlib: archive member:
.libs/libavcall.a(avcall-structcpy.o) cputype (18) does not match
previous archive members cputype (16777223) (all members must match)
libtool: link: ranlib .libs/libavcall.a
ranlib: archive member: .libs/libavcall.a(avcall-structcpy.o) cputype
(18) does not match previous archive members cputype (16777223) (all
members must match)
make[1]: *** [libavcall.la] Error 1
make: *** [all] Error 2

/path/to/libsigsegv-2.11/build-aux/test-driver: line 107: 25967 Bus
error               "$@" > $log_file 2>&1
FAIL: sigsegv1
/path/to/libsigsegv-2.11/build-aux/test-driver: line 107: 25974 Bus
error               "$@" > $log_file 2>&1
FAIL: sigsegv2
/path/to/libsigsegv-2.11/build-aux/test-driver: line 107: 25980 Bus
error               "$@" > $log_file 2>&1
FAIL: sigsegv3
/path/to/libsigsegv-2.11/build-aux/test-driver: line 107: 25986
Segmentation fault      "$@" > $log_file 2>&1
FAIL: stackoverflow1
/path/to/libsigsegv-2.11/build-aux/test-driver: line 107: 25992
Segmentation fault      "$@" > $log_file 2>&1
FAIL: stackoverflow2


On 19 March 2017 at 23:49, Karl Berry wrote:
> Bruno (Haible) has made test releases for clisp, libffcall, and
> libsigsegv so that we can test it for this year's TL. Bug reports should
> go to the mailing lists given by Bruno below. So anyone who is up for
> it, give it a try.
> I have not yet myself tried the new versions and Bruno's build
> instructions. After I do, I'll update the clisp info at the end of our
> Build/source/utils/README. Info is surely welcome.  --thanks, karl.
> The intended support matrix is as follows:
>                                   libsigsegv   libffcall   clisp
>     universal-darwin                  Y            Y         Y
>     x86_64-darwin                     Y            Y         Y

More information about the tlbuild mailing list