[tlbuild] PATCHES: --with-system-xpdf, various build system niggles...

Edd Barrett vext01 at gmail.com
Wed Jul 15 19:35:48 CEST 2009


On Wed, Jul 15, 2009 at 11:44:02AM +0200, Peter Breitenlohner wrote:
> It seems that OpenBSD does not (can not) encode inter-library dependencies
> into the shared libraries (as done for ELF libraries).  As a consequence on
> such systems pkg-config always assumes --static.  Can you try
> 	pkg-config cairo --libs
> where I get just "-lcairo ", and
> 	pkg-config cairo --libs --static
> where I get "-L/usr/XOrg-7.3/lib -lcairo -lpixman-1 -lfontconfig ...".
> You should get the same result in both cases. True?

puff% pkg-config cairo --libs
-L/usr/local/lib -L/usr/X11R6/lib -lcairo -lpixman-1 -lfontconfig
-lexpat -lfreetype -lglitz -lpng -lz -lm -lXrender -lX11 -lXau -lXdmcp
puff% pkg-config cairo --libs --static
-L/usr/local/lib -L/usr/X11R6/lib -lcairo -lpixman-1 -lfontconfig
-lexpat -lfreetype -lglitz -lpng -lz -lm -lXrender -lX11 -lXau -lXdmcp

There may not be that it can't, but that they have chosen it this way. I
am not sure to be honest.

> Contrary to this
> 	pkg-config poppler --libs
> (on Linux) gives "-L/usr/local/lib -lpoppler " (correct), and
> 	pkg-config poppler --libs --static
> gives the same result (wrong, lacking the library dependencies).

puff% pkg-config poppler --libs
-L/usr/local/lib -lpoppler
puff% pkg-config poppler --libs --static
-L/usr/local/lib -lpoppler

Dodgy .pc file then I guess?

> The whole problem is complicated by the fact, that the requirements for
> libpoppler (cairo, xml2, ...) depend on how poppler was configured. So
> ultimately this has to be fixed by the poppler developpers.
> How did you get poppler-0.10.7? From an OpenBSD binary package, or did you
> compile and install it.  In the later case you might try to fix the
> poppler.pc file by manually adding the required packages and/or libraries
> (taking cairo.pc as a template).

This is the official poppler package from
OpenBSD ports. I will notfy the maintaier soon. I guess it is not your
responsibility to work around this.

On another note I am attaching a failed config.log for the unquoted
POPPLER_VERSION malarky. Sorry I can't look into this more just yet, but
I will at some stage when I get time.

With regards to gettext, the BSD's do not ship with *any* GNU utilites
by default (other than gcc, but not for long, as PCC will take its place
soon). All third party software goes in /usr/local instead of /usr,
which is why icu and gettext have the same prefix.



Best Regards

Edd Barrett
(Freelance software developer / technical writer / open-source developer)


More information about the tlbuild mailing list