[tlbuild] PATCHES: --with-system-xpdf, various build system niggles...

Peter Breitenlohner peb at mppmu.mpg.de
Wed Jul 15 11:44:02 CEST 2009

On Tue, 14 Jul 2009, Edd Barrett wrote:

> puff% pkg-config poppler --modversion
> 0.10.7
> puff% pkg-config poppler --cflags
> -I/usr/local/include/poppler
> puff% pkg-config poppler --libs
> -L/usr/local/lib -lpoppler

Hi Edd,

as far as I can see, your problem is due to a bad poppler.pc file (lacking
Requires.private and/or Libs.private or such).

I suppose you have a file /usr/local/lib/libpoppler.la; what are the
dependency_libs listed in that file.

It seems that OpenBSD does not (can not) encode inter-library dependencies
into the shared libraries (as done for ELF libraries).  As a consequence on
such systems pkg-config always assumes --static.  Can you try
 	pkg-config cairo --libs
where I get just "-lcairo ", and
 	pkg-config cairo --libs --static
where I get "-L/usr/XOrg-7.3/lib -lcairo -lpixman-1 -lfontconfig ...".
You should get the same result in both cases. True?

Contrary to this
 	pkg-config poppler --libs
(on Linux) gives "-L/usr/local/lib -lpoppler " (correct), and
 	pkg-config poppler --libs --static
gives the same result (wrong, lacking the library dependencies).

The whole problem is complicated by the fact, that the requirements for
libpoppler (cairo, xml2, ...) depend on how poppler was configured. So
ultimately this has to be fixed by the poppler developpers.

How did you get poppler-0.10.7? From an OpenBSD binary package, or did you
compile and install it.  In the later case you might try to fix the
poppler.pc file by manually adding the required packages and/or libraries
(taking cairo.pc as a template).


More information about the tlbuild mailing list