A short manual for TEXworks
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“lowering the entry barrier
to the TEX world”
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1
Introduction

Donald E. Knuth decided to create a new typesetting system, which would
be called TEX, because there had been a change in the printing system used
for the volumes of his book The Art of Computer Programming and Knuth
found the result of the new system awful.
The goal of TEX was then to have a system which would always produce
the same documents independently of the actual machine they were produced
on. Knuth also designed the Computer Modern family of typefaces and the
METAFONT language for font description.
The work initiated in 1977 was finished (the languages were “frozen”) in
1989. TEX and METAFONT are not evolving any more except for minor bug
fixes (TEX versions are numbered following the decimals of π – now 3.1415926
– and METAFONT the decimals of the number “e” – now 2.718281).
TEX provides basic tools (commands/instructions/“primitives”) to define
typesetting; almost every detail has to be defined, but the language allows the
creation of macros for repeatedly used constructs. So collections of macros
are loaded through format files (i.e., pre-compiled large macro collections).
Knuth created an original default format (more or less 600 commands)
which is called Plain TEX. This facilitates creating documents.
The most widely used format is LATEX (Leslie Lamport, 1985), which provides more global commands and structures for documents (article, book,. . . )
allowing easier and faster work, but sometimes with loss of flexibility due to
the more or less rigid framework. Other formats are AMS-TEX, AMS-LATEX,
ConTeXt, and XETEX, each having specific goals and advantages (and drawbacks).
To extend the format, one loads “packages” which are collections of
macros specific to some aspects of typesetting.
From its specification in the late 1960s the TEX family had to evolve until
3
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now, last version March 2008, to take into account the developments in the
typesetting world outside TEX.
Some of the problems to answer were/are:
– taking into account other languages with “alphabets” larger than the
ASCII 1 one or with non latin characters altogether,
– having more fonts, there is not much variety in the fonts created with
METAFONT (few font creator use it),
– creating documents in other formats than the normal DVI 2 ,
– using the rich possibilities of other typesetting systems and formats like
PostScript and PDF,
– having more calculation and scripting facilities,. . .
To answer these questions and others, many “engines” and programmes
have been created around TEX, for example: pdftex, pdflatex, dvips, ps2pdf,
and METAPOST to open the TEX world to the possibilities of PostScript
and PDF. XETEX and XELATEXto be able to use the “normal” fonts found on
the different machines and to be able to cope with writing systems different
from the left to right systems which originated in Europe (latin and Cyrillic
letters and associates) – right to left, vertically, pictograms,. . . Or LuaTeX
and LuaLaTeX to have a powerful scripting language.
To use TEX and the systems of its family, one has to create a “source”
document as TEX is only a system to “transform” a source document into a
(beautifully) typeset document. This source is a simple text with typesetting
instructions and one needs a programme to create it: the editor.
There are many editors able to create a TEX source; some are general
editors, others are specifically designed for TEX: here comes TEXworks in.
TEXworks is a project to create a text editor for use with TEX family of
tools; we will refer to these as (LA)TEX. Instead of creating a new sophisticated program, equipped with multiple tool-bars to meet any need, TEXworks
provides a simple editor, offering at first sight only a limited set of tools for
text editing as well as a single button and a menu to typeset a (LA)TEX text.
The idea to create the editor came to Jonathan Kew, the initiator and
leader of the project, after a long period of reflection on the reasons why
potential users tend to keep away from (LA)TEX, as well as pondering the
success of the TEXshop editor on the Mac.
Finally the goal was also to provide the same editor on many operating
systems: TEXworks currently runs on Linux, Mac OS X and Windows. The
1. “American Standard Code for Information Interchange”: a character encoding
scheme including only latin characters found in English, some common punctuation characters, and a few other symbols such as % or $
2. “Device Independent”: format of files produced by TEX
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interface is always the same and the program offers the same functionality
on all three platforms.
The first section of this manual explains how to install the software. In
the second section, we describe the interface and create a first document
showing the basics of TEXworks. In the third section the advanced tools
provided by TEXworks are presented; you should read this section only after
mastering the basic working of TEXworks. These advanced tools allow much
more effective working practices. The last section, as annexes, provides lists
of the keyboard shortcuts, the regular expression search/replace system, and
the keywords for auto-completion. Finally, a short bibliography closes this
manual.

2
Installation

TEXworks is only a text editor; to be able to create documents with
EX and to typeset them to PDF, we also need what is called a TEX
distribution. This is a collection of programs and other files which will be
automatically called by TEXworks during its work. Thus, you need to install
a distribution: we will do that before starting TEXworks for the first time, as
this way, TEXworks will automatically find what it needs.
TeX Live (http://www.tug.org/texlive/), a combination of teTeX,
macTeX and XEmTeX, is available for all three operating systems (Linux,
Mac OS X, Windows). The current version is TeX Live 2010. Note that you
need a reasonably recent version of TeX Live (2008 or later at the time of
writing) to use all features of TEXworks.
For Linux: every Linux distribution includes a TEX distribution, but it
may not be installed by default and you will have to use the Linux package
management tools to do that. As alternative to TeX Live, one can use teTeX
(http://www.tug.org/teTeX/, a predecessor system to TeX Live.
(LA)T

For the Mac: MacTeX, a new distribution based on gwTeX and XeTeX,
is available; see http://www.tug.org/mactex/.
For Windows: a very popular distribution is MiKTeX (http://www.
miktex.org/). MikTeX has an update programme, which has also been
ported to Linux. You can also use the XEmTeX distribution (http://www.
xemtex.org/).

2.1

Under Windows

After the installation of the TEX distribution, obtain TEXworks by downloading the setup from the TEXworks web site: htp://tug.org/texworks/;
6
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you will find binaries for Mac and Windows at http://code.google.com/
p/texworks/downloads/list.
Simply install TEXworks by running the setup file. During the installation, you will be asked where to install the program, if you want to create
shortcuts, and if you want to always open .tex files with TEXworks. There
are reasonable default values that should work well for most users.
If you want full control over how and where TEXworks is put, you can
also download the .zip archive from the website and unpack it wherever you
like. Note that in this case, shortcuts and file associations must be created
manually.
When you start TEXworks for the first time, it creates a folder named
TeXworks in your home folder 1 . This folder will contain some sub-folders for
auto-completion, configuration, dictionaries, templates, and interface translation/localisation files — we will see these in more detail later. 2
NB. At the time of writing, if <your name> contains any non-ASCII
characters (for example accented characters), some functions of TEXworks
may not work correctly. For example, the spell-checker and forward/reverse
synchronization between the source and .pdf will be impaired.

2.2

Under Linux

Several common Linux distributions already have packages for TEXworks.
They are adequate for most users and facilitate installing TEXworks considerably.
If your Linux distribution does not provide recent, adequate packages,
you need to build TEXworks from source yourself, which is fairly easy on
Linux. After the installation of the TEX distribution, go to http://code.
google.com/p/texworks/wiki/Building and follow the instructions suitable for your Linux distributions. Also see the annex section A.4.
Once the program is installed, start TEXworks. The folders .TeXworks
and .config/TUG will be created in your home directory.

2.3

Under Mac OS X

After the installation of the TEX distribution, obtain TEXworks by downloading the archived program from the TEXworks web site: http://tug.
1. on Windows XP, your home folder is C:\Documents and Settings\<your name>.
On Windows Vista/7, your home folder is C:\Users\<your name>.
2. TEXworks will save its preferences in the registry: \HKEY_USERS\S-...\Software\
TUG\TeXworks. If this is erased, it will be recreated with default values at the next use.
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org/texworks/; you will find binaries for Mac and Windows at http://
code.google.com/p/texworks/downloads/list.
You need to get TeXworks-Mac-0.2.3r466.zip 3 which contains everything you need.
It is a standalone .app package that does not require any Qt files installed
into /Library/Frameworks, or other libraries into /usr/local/lib. Just
copy the .app anywhere you like and run it.
On Mac OS X, the TEXworks resource folder will be created in your
Library folder (~/Library/.TeXworks/), inside your home directory. Preferences are stored in ~/Library/Preferences/org.tug.TeXworks.plist
which you can delete if you ever suspect it is causing problems.

2.4

Ready!

Finally, some files may need to be added to the “personal” files that
TEXworks creates. As the exact location of these dependends on your platform, this will be referred to as <home>/TeXworks or the TEXworks resource folder later in this manual. On Linux, this is ~/.TeXworks, on
Windows XP it is C:\Documents and Settings\<your name>\TeXworks,
on Windows Vista/7 it is C:\Users\<your name>\TeXworks, and on the
Mac it is ~/Library/.TeXworks/,
After installation and first run, have a look in the sub-folders of the
TEXworks resource folder and delete any qt_temp.xxxx files; they are temporary files left behind and could interfere with the normal ones, which are
installed in the same folder, later on.

3. Version at the time of writing this manual.

3
First steps

Let’s now see how to create a first document: for this you’ll need to type
some text in the editor window of TEXworks. (LA)TEX is not a WYSIWIG 1
software, so you’ll have to type the text and the instructions for formatting
it and you’ll see the result only after “typesetting” the text. This looks a
little bit dry, but one very quickly gets used to it and it is well worth the
effort.

3.1

Interface summary

When one opens the editor, it shows a very sparse interface: a title bar, a
menu bar, two small toolbars, a large typing zone (white) and, at the bottom,
a status bar. We are in the source/editor window. If you already typeset the
document previously, the resulting .pdf will be shown on the right in the
preview window.
The first toolbar has a button to typeset and an dropdown menu to choose the format for typesetting (we’ll
choose pdfLaTeX). Knowing that the keyboard shortcut for typesetting is
Ctrl T (Mac OS X:
T ) and that we almost never change the format,
we could even hide this toolbar. The selection of a format for compiling can
also be changed through the Typeset menu.
The second toolbar provides the standard
functions: New document, Open, Save |
Undo, Redo | Cut, Copy, Paste | Search, Replace.
1. What You See Is What You Get.

9
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Title bar
Menu bar
Toolbars

Editing zone

Preview

Status bar

3.2
3.2.1

Creating a document
Writing the document

As an example of the use of TEXworks we will work with LATEX, but any
other TEX system is possible. In particular, if you need to use some special
fonts – a mandatory font for an official template, non latin alphabets, etc. –
the XETEX system is very powerful. 2
Let’s create now our first document. Enter the following text exactly as
shown. To show some of the features of TEXworks/LATEX, it is in French
intentionally.
\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{geometry}
2. See the references for pointers to XETEX and XELATEX.
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\geometry{a4paper}
\usepackage[frenchb]{babel}
\title{Premier document}
\author{Un TeXnicien}
\date{}
\begin{document}
\maketitle
Voici un texte accentué en français!
\end{document}

Save the file in a folder for test documents (e.g., <home>\TeXworks_
tests); call the file first.tex. Note that it should have a .tex extension.

3.2.2

Typesetting the document and viewing it

or by Ctrl
Next we start typesetting 3 by clicking the green button
T (Mac OS X:
T ).
A new panel opens between the typing area and the status bar: the output
panel, labeled Log; everything LATEX is doing is displayed there 4 . When LATEX
finishes this panel disappears (if there no error occurred) and a new window
will appear; in this new window, the Preview window, you can see a page
with a title “Premier document” followed by the name of the author “Un
TeXnicien”, both centred, the text “Voici un texte accentué en français !”,
and a page number at the bottom centre.
Notice that the mouse cursor is like a magnifier in the new window. If
you press (and hold) the left button of the mouse you can see the text under
the magnifier much bigger (it is a magnifier, isn’t it!); you can move the
magnifier and so inspect the text in detail.
To go back to the source, you can just click in its window or better use
Ctrl
’ (Mac OS X
’ ). This shortcut toggles between the two
windows. See also section 5.1 to automatically move to a specific location in
the output from the source or vice versa.
3. We also use the words “compilation” and “to compile” for the same action; indeed
LATEX works on the source file to produce a .pdf output, so there is a compilation.
4. see page 13 for a picture of the panel
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The work of LATEX

Let’s shortly analyse the result to understand what LATEX did and why,
now. Introductions and full tutorials can be found on the internet: see for
example lshort 5 which should be installed as part of your TEX distribution,
and is also available from CTAN. 6
First, we ask to create a document of the article class: this defines the
global layout of the document.
Next, we say that the input document (the source) is saved with the Unicode encoding utf-8 and that it may contain characters which are not present
in the standard ASCII without accents. We also want to use an output encoding T1 (the modern TEX encoding); we also want an A4 document and
not the default US letter size. Finally, we make it clear that the typography should follow the French rules using the babel package. 7 Those general
instructions for the work are done by packages called with options.
Lastly, we finish the declaration part of the document, the preamble,
giving the title, the author, and the date of the document; here we specify
no date.
Next comes the body of the document, which describes the actual content,
between the lines \begin{document} and \end{document} (these are LATEX
commands).
Let’s do some experiments to show the effect of these instructions. For
this, we put a % in front of the instructions; the % and everything after it
will be considered as comment, which will be ignored by LATEX. 8
Comment out the line \usepackage[utf8]{inputenc}, and typeset the
file. You should see that the accented characters are now displayed incorrectly in the preview window. If, in addition, you also comment out the line
\usepackage[frenchb]{babel}, LATEX will give an error. Just hit ←- to
continue the typesetting.
After these experiments, let’s modify the text as follows:
\begin{document}
\maketitle
\tableofcontents
5. The (Not So) Short Introduction to LATEX 2ε
6. Comprehensive TeX Archives Network, a network of mirror servers of the central
CTAN; there, one can find almost everything about TEX, LATEX, and more: http://www.
ctan.org
7. This influences, e.g., automatic hyphenation of words or the way punctuation characters are typeset
8. Notice that the comments are, by default (this can be changed), coloured red by
TEXworks, so we see them well.
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\section{Petite démonstration}
Voici un texte accentué en français!
Suite du texte entré après avoir fait un retour chariot. Dans
l’éditeur on peut demander un passage automatique à la ligne
du texte saisi; mais le numéro de ligne n’est incrémenté que par un
retour chariot.
Nouvelle ligne en passant une ligne dans la source: c’est la
manière d’indiquer un changement de paragraphe.
\end{document}

Redo the previous experiments and observe the changes which appear.
Note that entering only one carriage return doesn’t create a new paragraph. In LATEX, one has to have an empty line for that. In TEXworks, the
line number of the source (on the right in the status bar) numbers the lines
created with carriage return, not the wrapped lines.

3.3

And when errors occur?

When you create a document for typesetting with LATEX, you cannot
avoid making mistakes: forgetting a closing brace or an \end{} command
to close an environment, using mathematical commands without switching
to mathematical mode, etc. When you compile and there is an error, LATEX
stops, giving you a chance to deal with the problem. This is shown by the
stopping of the scrolling action in the output panel, and an error message
being displayed, with LATEX waiting for an instruction to know what it should
do. One sees the typing cursor in the line between the output panel and the
status bar: the console bar.

Output panel

Console bar
Status bar
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The error message is on many lines, for example like this:

! Undefined control sequence.
l.168 ... fermante ou d’une commande \veb
+\end{}+ de fermeture d’un...
?

LATEX says that it doesn’t recognize the command name, sometimes suggests to see the manual or to type h (plus ←- ) for help, points to the
line number (here 168), and shows the place of the error at the cut of the
line (here at \veb). Finally, it shows that it waits for an action from us by
displaying a single question mark.
There are different possible actions:
– Type ←- and ask to continue as if nothing happened; sometimes this
allows to finish compiling, but there will be an error in the result.
– Type h ←- to ask for help; this help in not always clearer than the
error message, but often gives a clue.
– Type i ←- to tell LATEX that we will propose a replacement text. Enter
the text followed by ←- ; it will be used, beginning at the start of the
error, but you should correct the source afterwards as LATEX never
changes that.
– Type x ←- to stop compilation. This is the traditional (LA)TEX way to
kill a typesetting process.
We can also kill the typesetting by repeating the action used to start
it: the green typesetting button will have changed to a red one with
a white cross
. By clicking on that button or by hitting Ctrl T
(Mac OS X:
T ) again, the LATEX process is terminated. The
output panel is still visible and so one can still see the error message.
You should note that sometimes an error appears far from its actual
position. For example, when opening an environment but not closing it,
LATEX doesn’t see the error before it encounters another end of environment
without closing of the first one. The error is often only picked up at the
\end{document} command, which shows that another environment was not
closed!
Sometimes, an error still occurs during subsequent runs of (LA)TEX even
after it was corrected in the document. This can happen because (LA)TEX
creates a number of intermediary files which can still contain the original,
erroneous code. Therefore, it is advisable to remove those files after fixing
an error. TEXworks provides a command to facilitate this — see section 5.6.
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To help you in finding and fixing error (at least if you are using LATEX),
TEXworks comes with a small script that extracts all errors, warnings, and
other noteworthy messages from the console output and presents them to
you in a simple, tabular form.

Here, you see a list of LATEX messages, color-coded and sorted by severty.
Red represents errors, yellow indicates warnings, and blue stands for overand underfull box warnings. Next to the color bar, you see the name of the
file in which the error occured. Next to that, you see the line number (if the
script was able to determine that), as well as an excerpt from the console
output telling you what the error was. Moreover, the filename is a link which
will take you to the file (and, if a line number could be determined, also the
line) where LATEX reported the error. Hopefully, you can quickly fix any
errors that may occur this way.
In case you are not using LATEX, this script may be of little use, particularly if the console output is formatted differently. In this case, you can
simply disable the error parsing hook script (see section 6.2).

3.4

Changing TEXworks parameters for convenience

If the default font of the editor doesn’t suit you, it is possible to change
it from Format→Font. . . by selecting a new one in the dialogue box
which appears. This change will apply only to the current window, and until
TEXworks is restarted.
From the Typeset menu or from the drop-down on the Typesetting
tool bar, you can change the compilation format. Again this change will
only be temporary and for the current document.
To have permanent changes, you need to change the preferences through
the Edit→Preferences. . . menu, using the Editor tab for the font and
the Typesetting tab for the compilation format: the default format is at
the bottom of the tab.

4
Going further: Editing tools

When you have had some practise with TEXworks, you’ll find the need
for more effective tools. Many of them are bundled with TEXworks. We are
going to see some of them now.

4.1

Creating a document from a template

Most documents you will create will use the same instructions in the
preamble, the same layout settings, similar heading and so on. You can use
predefined templates to get started quickly or create your own with all of
these settings already in place.
Use File→New from template. . . or Ctrl Shift ⇑ N (Mac OS X:
Shift ⇑
N ). A dialogue box opens to allow you to select one of the
templates. After selecting one and pressing OK, a document is created and
you can start to work.
If you want to create a personal template, you just have to create a suitable document with everything you always want to do (and perhaps marking
places to fill in the rest) and save it as a .tex file in the <home>\TeXworks\
templates folder, or a sub-folder of it, if you wish.

4.2

Creating a project using several source
files

When the source becomes long, it is sometimes difficult to navigate and
maintain it. Then, it is useful to split the source in different smaller files:
one file will be the main document, with the preamble and the document
16
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environment, as well as calls to the “sub-documents”. 1
But there might be a problem if you want to start typesetting/compilation
in a sub-document: as there is neither a preamble nor a document environment there, LATEX will stop immediately with an error.
To tell TEXworks that it should typeset the main document, one adds at
the very beginning of the sub-document the instruction:
% !TeX root = path/main_file.tex
for example:
% !TeX root = manual.tex
If the main file is in the same folder, its name is enough, as in the above
example. Otherwise, you must also give the path to the main document
(preferably relative to the sub-document in question, e.g., ../manual.tex).
Notice that the slash / and not the backslash \ should be used as directory
separator even on Windows.
Further, with MiKTeX, the call to a sub-document \input{name.tex}
should include the extension .tex to ensure proper SyncTeX functionality
(see section 5.1).

4.3

Spell-checking

You can turn on automatic spell-checking of your source document from
Edit→Spelling→<language>.
During typing, every word the spell-checker considers wrong is underlined
by a red wavy line. A right-click on the word opens a contextual menu in
which there are some replacement suggestions. Click on the desired word to
make the replacement.
Before using the spell-checker, you need to install dictionaries in the right
folder of TEXworks: <home>\TeXworks\dictionaries.
On Linux, the dictionaries are usually taken from the folder /usr/share/
myspell/dicts — the default path for myspell dictionaries. Note that the
maintainer of your TEXworks package may have changed this to reflect the
file system layout of your Linux distribution. You can override this default
by setting the TW_DICPATH environment variable before running TEXworks.
One can use the available dictionaries for OpenOffice.org and other free
software; 2 if you have Mozilla Thunderbird with spell-checking, you can
copy its .aff and .dic files as well, for example. It is possible to ask
1. Called by the commands \input{} or \include{}, see LATEX manuals for more
information.
2. See,
for
example,
http://lingucomponent.openoffice.org/download_
dictionary.html
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TEXworks to enable spell-checking by default by setting a dictionary in Edit
→Preferences. . . →Editor→Spell-check language.

4.4
4.4.1

Search and replace
Standard functions

The options of the menu Search — Find. . . , Find again, Replace. . . ,
Replace again, and Go to Line. . . ( Ctrl F , Ctrl G , Ctrl R
, Ctrl Shift ⇑ R , and Ctrl L , respectively) — are standard actions
(Mac OS X:
F ,
G ,
R ,
Shift ⇑ R , and
L );
the first and the third open a dialogue box:

There are the usual options: Wrap around, Find backwards, Search/Replace
within selection, or Find all occurrences. The following options are also usual:
Case sensitive and Whole words. By default, the search is forward, towards
the end of the document.
The option Search/Replace in all open files is also a frequent choice, but
not as much as the others; this allows, for example, replacement in all the
files of a project – pay attention, though, as this is very powerful.
The last option, Regular expression, is detailed in the next sub-section.
In the Search menu there are other options:
Copy to Find copies the currently selected text into the Find field of the
Find dialogue or the Replace field of the Replace dialogue; you still
need to open the dialogues separately
Copy to Replace copies the currently selected text into the With field of
the Replace dialogue
Find Selection uses the current selection for a search without opening the
Find dialogue — very fast
Show selection scrolls the view to the currently selected text — useful if
word wrapping is turned off and you moved in the document using the
vertical scroll bar on the right
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Regular expressions

The regular expressions provide a very powerful tool, but they require
some effort to be well understood. To understand them fully would require
a manual of its own 3 , so we’ll only give some simple ideas of use.
Suppose we have the following text:
Voici du texte pour tester les expressions régulières dans du texte
accentué.
Voici du texte pour tester les expressions régulières dans du texte
accentué.
Voici du texte pour tester les expressions régulières. Voici du
texte pour tester les expressions régulières.
truc
truc
tél.: 010-99-99-99
tél.: 00.32.10.99.99.99
tél.: 00/32-10/99.99.99

We want to
1. insert an empty line after each “accentué” (to create paragraphs in
LATEX), but not after the three telephone numbers;
2. replace each tab character between the two words “truc” of the fourth
paragraph by three spaces; and finally
3. make the telephone numbers consistent by replacing the various punctuation characters by spaces.
For 1., in the dialogue box Replace ( Ctrl R ) for Replace: we put
›\n‹ 4 and in With: ›\n\n‹. ›\n‹ is the code to match or insert a line feed.
You will need to select the first four paragraphs and the beginning of the
fifth (the first telephone number) and to tick the Replace within selection
and Regular expression options; if this was not done and an empty line has
been inserted after each line, select the telephone lines and do the reverse
action: replace ›\n\n‹ by ›\n‹. So we replaced one line feed by two, creating
an empty line.
For 2., use ›\t‹ and ›␣␣␣‹ 5 . ›\t‹ is the code which represent a tab, while
a space is typed in literally (here represented as ␣).
3. Such manuals exist on the internet
4. the ›‹ are used here only to show the limits of the entered text and they should not
actually be entered
5. These are three space characters
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For 3., find ›-|\.|/‹ and replace with ›␣‹. Here, ›|‹ provides alternatives
(-, ., or /); for the dot we have used ›\.‹ because the dot alone is a regular
expression code which represents any character and we would have replaced
all the characters by spaces! We therefore have to use a code — prefixing the
dot with a backslash tells specifies that the normal meaning of the dot should
be used instead of the special meaning it usually has in regular expressions.
If one has strings of the same character but of different lengths (for example 3, 4, or 5 times the sames character e) and one wants to truncate all
these strings to a string with less characters (for example 2), one can ask to
replace the string ›e{3,5}‹ by ›ee‹.
If one wants to insert the same string at the beginning of some paragraphs
separated or not by an empty line, for example ›\noindent␣‹ or ›\item␣‹,
one can replace ›\n\n‹ or ›\n‹ by ›\n\n\\noindent␣‹ or ›\n\\noindent␣‹.
Pay attention, we have a double \ in front of noindent to get one (\noindent)
because \ is an escape character in regular expressions (we’ve met it before
in the expression \.)!
If it were making sense, we could replace all the letters between “a” and
“m” by “$” using ›[a-m]‹ and ›$‹.

4.5
4.5.1

Other tools for editing and error tracking
Standard tools

It is always possible to undo an action using Edit→Undo or Ctrl Z
(Mac OS X:
Z ): this way you can undo stepwise! The inverse action,
redo, is available as Edit→Redo or Ctrl Alt Z (Mac OS X:
Z ).
TEXworks also provides the standard editing tools such as the clipboard;
therefore one can select, cut/copy and paste a piece of text normally.
You can select with the mouse by dragging over the desired text, or by
double-clicking to select a word. Using the keyboard, holding down Shift ⇑
while moving using the arrow keys will select text. You can also move and
select word by word moving left or right holding Ctrl Shift ⇑ down (
Shift ⇑ on Mac OS X). The clipboard shortcuts are the ones you’ll find in
almost every program: Ctrl X to cut, Ctrl C to copy, and Ctrl V
to paste (
X ,
C and
V , respectively, on Mac OS X).
You can easily change the case of a selection — put everything upper
case or lower case — using Edit→Change case and next, depending on
the desired effect, ALL UPPERCASE, all lowercase, or Toggle Case
(which toggles the case of each letter individually).
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It is also convenient to show the line numbers, as all error messages refer
to these numbers; you can toggle the line numbers, on the left of the editing
panel, from Format→Line Numbers.

4.5.2

Commenting

When preparing a document with (LA)TEX, it is often useful to prevent
compilation of a portion of text to be able to locate an error; you can do
this piece by piece until you find the part which causes the error. To do this,
commenting the source block by block is needed.
We have seen that the symbol % marks the beginning of a comment. To
comment a big piece of text, it is sufficient to select it and ask to mark it
as comment Format→Comment or Ctrl Shift ⇑ ] (Mac OS X:
Shift ⇑ ] ). To remove the comment, select the lines and choose Format
→Uncomment or Ctrl Shift ⇑ [ (Mac OS X:
Shift ⇑ [ ). 6

4.5.3

Matching delimiters

A frequent error is to forget a closing symbol: parenthesis, bracket, square
bracket, etc. TEXworks helps with a tool to show the pairs of symbols: when
the cursor moves over one of these symbols, its partner is briefly highlighted.
You can also select an entire block using Edit→Balance Delimiters or by
B ). Thus, you will immediately
the shortcut Ctrl B (Mac OS X:
see the scope of the block.

4.5.4

Smart quotes

Another similar error, but this time semantic and not hindering typesetting, is in the use of quotes when one wants to give focus to some text.
There are two types of quotation marks, in English, the ‘single’ quotes
and the “double” quotes. They are formed by ‘ and ’; these are not the
quotation marks used in programming and found on the keyboard: " and ’.
Using the TEXworks smart quotes system, one can use the latter as normal
to automatically produce the typographically correct single/double opening
and close quotes.
In a .tex document, select one of the smart quotes system: Format
→Smart Quotes→TeX Ligatures, →TeX Commands, →Unicode
Characters. Then, when you want to start a quoted section in your text,
6. On some keyboards, like the French one, it is impossible to use Ctrl Shift ⇑
or Ctrl Shift ⇑ ] ; these shortcuts can be changed, however — see annex A.1

[

4. Going further: Editing tools

22

let’s say enclosed in double quotes, type ", then the text to be quoted, and
finish again by "; TEXworks will automatically insert the correct opening
quotes ‘‘ and later the correct closing ones ’’. The three options give the
same result in the typeset document, but TeX Ligatures should work best
in most cases.
Finally, it is possible to define personal quotation marks systems (in the
file smart-quotes-modes.txt in the configuration folder of the resource
folder).

4.6

Auto-completion

Another tool which rapidly becomes indispensable is auto-completion.
Indeed, when you use (LA)TEX, you have to continuously enter codes to, for
example, create environments; you also have to remember to close every
group you open.
Auto-completion allows you to type a keyword, hit the  key, and have
TEXworks insert the (LA)TEX command or environment code automatically.
As an example to insert “LATEX”, we have to type \LaTeX. This is not
difficult, but entering “\” followed by the word “LaTeX” with alternating
capitals and lower case letters could become annoying after a while. 7 With
auto-completion, you just enter latex and hit  to get \LaTeX. You
just have to take care that there is no letter directly preceding or succeeding
latex — e.g., alatex —, or else the mechanism might not pick up the correct
keyword.
Another example is bmin, which gives
\begin{minipage}{}
•
\end{minipage}•

with the cursor between the empty pair of curly brackets where you need to
enter the size of the minipage. See the section A.3 for a list of the keywords
for auto-completion. Notice the “•” in the minipage environment. They are
placeholders which can be reached by Ctrl  (
 on the Mac),
repeating this shortcut cycles forward through the placeholders; by Ctrl
Shift ⇑  (
Shift ⇑  ), you can also cycle backwards.
If a partial keyword is given, repeatedly hitting  will cycle through
possible completions. For example, bali (the b commonly indicates the beginning of an environment, \begin{}) creates the align environment after
7. In particular with keyboard layouts where \ is not directly accessible.
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one  , next align*, and after that, in succession, alignat, alignat*,
aligned, alignedat, and alignedat with options; to access the last environments directly, they have their own codes which start by bali (balis,
baliat, baliats, balied, baliedat and baliedato).
If you want to create your own keywords, you can add a .txt file in the
completion folder inside the resources folder. The entries in the file should
have the following format:
bfigo:=\begin{figure}[#INS#]#RET##RET#\end{figure}•
\bibliography{#INS#}•

In the first case, bfigo is the assigned keyword (with :=) to be converted
into a figure environment with an optional argument; there are two carriage
returns (#RET#) after the begin, i.e., an empty line, and the cursor is placed
between the square brackets (at the position of #INS#). “•” is a place holder
as introduced before.
In the second case, we give ourselves a shortcut, which will let us type
the first part of \bibliography{} and have TEXworks convert it to the full
name plus braces (with the cursor between them). In this case, the keyword
is the instruction itself.
Note that the .txt file containing the auto-completion information needs
to be UTF-8 encoded — this is the default encoding for all files created with
TEXworks.

5
Going further: Other tools

5.1

SyncTeX’ing between source and preview

When you are reading a document in preview and see something to
change, it is convenient to go immediately to the corresponding place in
) and click at the
the source. To do that, hold down Ctrl (Mac OS X:
appropriate place in the preview window; the cursor will move and highlight
the corresponding location in the source window. The same is true in the
in the source will highlight the same line in the
other direction: Ctrl
1
preview window.
Here a remark for users under Windows: this only works if all the
names for folders/files/. . . do not have accented characters. If, for example, your document is in C:\Documents and Settings\Propriétaire\My
Documents\thesis it will not work because of the é in Propriétaire!

5.2

Special comment strings

Special comments, at the very beginning of the files, can be used to
manage two other aspects of the compilation.
By default, TEXworks uses the “utf-8” encoding for saving files, but some
files could be saved in another encoding. Common ones are “latin1”, which
is the dominant encoding on Windows when using western languages, and
“Apple Roman” which is dominant on Mac OS. To set a different encoding
for a specific file one can put the following at the beginning of that file:
1. It is also possible to use a right-click ( ) to open a context window and select “jump
to PDF” or “jump to source”.
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% !TeX encoding = latin1

If we want to compile a file with another programme than the default
TEX or LATEX, we put at the beginning of the file:
% !TeX program = <the_programme>

for example:
% !TeX program = xelatex

Pay attention to this last instruction. You have to use the name of the
programme here which should be used for the whole project, as it is the
programme name which is first encountered when starting typesetting (the
one from the sub-document in which you are). TEXworks will use that programme, even if another name appears in the main document!
When opening a document which contains a % !TeX program line, the
specified programme will become the one to use (its name will appear in the
drop down menu in the toolbar); you can, however, override this by selecting
a different one from the drop down list, if you want.
In addition, you can set the spell checking language by a similar comment
line:
% !TeX spellcheck = <language_code>

The language codes available on your system are listed in parentheses in Edit
→Spelling next to the human-readable name of the language.

5.3

Formatting the source for legibility

To facilitate legibility of the source, one can use indentation as programmers do:
\begin{itemize}
\item First element of the list;
\item second element;
\item last element:
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\begin{itemize}
% beginning of a sub-list
\item first sub-element;
\item second sub-element.
\end{itemize}
\end{itemize}

This increases legibility, but works well only on short lines, without text
wrapping; or if one chooses not to use text wrapping by unchecking Format
→Wrap lines.
The command Format→Indent or the shortcut Ctrl ]
(Mac OS
X:
] ) will indent the line, or the selected lines, by inserting a tab
character. You can repeat the process to increase the indent.
To remove one level of indentation, use Format→Unindent or the
[
on Mac OS X). 2
shortcut Ctrl [ (
As indent only indents the first part of very long (wrapped) lines, this
is not very satisfactory in some cases. But one can ask TEXworks to split
a long line (longer than the width of the editing window) into short ones
adding a hard coded line feed. Format→Hard Wrap... opens a dialog
box in which you can specify the width of the lines; you can also re-format
lines which have already been split.

5.4

Showing the tags

When a document is becoming long and you want to move to a specific
place (a chapter, a section, a subsection, . . . ) you normally need to scroll
the editing window to find the desired location, or use the Find dialog if you
remember a keyword in the chapter’s title.
To the same end, though a lot more comfortable, you can also use the
structural information in the document to navigate the source: Window
2. See the modified shortcuts if your keyboard layout does not allow these actions.
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→Show→Tags opens a panel showing the information detected by TEXworks.
Clicking on an item in the panel moves the cursor to the corresponding part
in the source. That panel, like any other, can be resized by dragging its
border.
The same action is possible in the PDF window from Window→Show
→Table of contents, but this only works if one has created structure tags
in the PDF file using the package hyperref.

5.5

Organising the windows

By default, the editor/source window opens on the left and the preview
one on the right (when the corresponding PDF file exists), thus splitting the
screen in two.
You can change the position of the windows in the Window menu.
→Stack and →Side by side give the default effect if there is only one
document open. If not, →Stack creates a mosaic with all the windows. The
other options allow to place the windows for your convenience. It is also
always possible to resize and move the windows manually, of course.
For the preview you can change the way it is presented and of course the
zoom by View→Actual size, →Fit to width and →Fit to window; you
can also zoom in and out. Shortcuts exist for all these actions and are shown
next to the menu items.

5.6

Cleaning the working folder

Very soon when one uses (LA)TEX, one discovers that the working folder
is cluttered by many files which have the name of the source file but different
extensions: .aux, .log, .toc, .lof, .lot, .bbl, . . .
All these are files needed by (LA)TEX to be able to create the table of
contents, lists of figures/tables, the bibliography, the cross references and,
also very importantly, to keep track of what it did (in the .log file).
Apart from the external files, images, pictures, . . . , the only files required
are the .tex files, the sources of the document. One can erase all the others.
Sometimes, this is even necessary when (LA)TEX gets stuck after an error.
This can be done using a TEXworks command from the File menu:
→Remove Aux files . . . .
When you use this command, a dialog box opens in which you can
check/uncheck the files you want to remove. 3 The dialog box will only list
3. The name of the main file is used to list the possible candidates for deletion.
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files that actually exist in the foler; if you removed all these auxiliary files
before, you get a message box saying that there is no file to remove at the
moment.
The list of auxilliary files which are taken into account is defined in the
file texworks-config.txt in the configuration folder of the TEXworks
resources folder. You could add some if required.

5.7

Changing the configuration

We have seen in section 2 (on page 6) that the first time you use TEXworks,
it creates a resource folder and also that it saves default preferences.
It is possible to define a personal place where one wants the resource folder
and the preferences. This can be handy when one wants a portable system
(e.g., on an USB stick) or when one wants to easily access the templates or
completion folders for modifications.
For this, create a file texworks-setup.ini in the programme folder in
which you specify the path to the folder containing the completion, configuration, dictionaries,. . . folders and the configuration file (texworks.ini);
there will be two lines:
inipath=C:/myfolder/TW_conf/
libpath=C:/myfolder/TW_conf/

inipath for the configuration file and libpath for the necessary folders.
Here, TW_conf would replace the resource folder TeXworks. Note that the
referenced folder (here TW_conf) should exist — it will not be created —,
and that the / is used even on Windows (instead of the common \).
If one wants to put the resource folder in the programme folder as a
subfolder, one can use an instruction like inipath=./TW_conf/; all relative
paths are taken to be relatve to the TEXworks programme folder (on Mac
OS X, the folder containing the app package is used).
One can also add a line like
defaultbinpaths=C:/Program Files/MiKTeX 2.7/miktex/bin

to specify where the programmes of the TEX distribution are located; but
this instruction is not yet completely operational, especially under Windows.

6
Advanced use: Scripting

6.1

Introduction to Scripting

All the functions and utilities described so far were built into TEXworks
by default. While some of them could be configured or customized to a
certain extent, they are intended to suit the most common needs of a general
audience. However, the TEX world is very large and diverse. In order to
enable users to address their special needs — from simply making some text
bold to fulfilling special requirements for the next book or scientific paper
you want to publish —, the core functionality of TEXworks can be extended
or modified by the use of scripts.
Scripts are simple text files that you can open, read, or modify in any
text editor (including TEXworks, of course). They are written in a specific
scripting language that is essentially a programming language. At the time
of writing, TEXworks supports QtScript 1 (built-in), Lua (with a plugin), and
Python (with a plugin). To see which scripting languages are available on
your system, use the Scripts→Scripting TEXworks→About Scripts. . .
menu item.
Writing scripts is beyond the scope of this manual, but is documented
separately. Here, only the installation and usage of scripts will be discussed.
TEXworks distinguishes between two types of scripts: standalone scripts
and hook scripts. The primary purpose of standalone scripts is to add new
functionality to the program. If you need a new function, such as a command
to make the selected text bold, a standalone script is the one to choose. These
scripts get an item in the Scripts menu, and you can run them simply by
clicking on that menu item (or by using a keyboard shortcut, if the script
1. A scripting language similar to JavaScript provided by Qt.
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provides one).
Hook scripts, on the other hand, are meant to extend existing TEXworks
functions. They are hooked into the code at specific places, e.g., after the
typeset process has finished or after a file was loaded, and can add or modify
whatever TEXworks is doing. One example for this would be a script that
analyses a newly loaded file and sets the spell-checking language based on
babel commands found in the document. Thus, hook scripts do not show up
in the Scripts menu but are instead run automatically when the TEXworks
function they modify is used.
You can easily determine which type of script you have by opening the
script file. Near the top of the file, you should find a line similar to
// Type: standalone

Alternatively — once the script is installed —, you can use the “Manage
Scripts” dialogue available from Scripts→Scripting TEXworks→Manage
Scripts to display this information.

6.2

Installing Scripts

A word of caution first: do not install scripts from a source you do not
trust! Before installing scripts, you should make sure that the file you are
about to install indeed does what you expect. Scripts are very powerful —
they can do almost everything a normal program can do. So while there
are some security precautions built into TEXworks, you should still be aware
that scripts could potentially harm your computer and cause (among other
things) crashes and data loss. In particular, scripts can read, create, and
modify arbitrary files on your hard drive.
That said, installing scripts is very simple. Script files are generally installed in <resources>/scripts or subdirectories of it. These subdirectories
are shown as submenus of the Scripts menu, so they can be used to group
and categorize scripts. This is especially useful if you use many different
scripts that would otherwise make the Scripts menu very confusing. One
easy way to open the scripts folder is the Scripts→Scripting TEXworks
→Show Scripts Folder menu item.
Since scripts are usually simple plain-text files, they do not come with
fancy installers. To install them, simply copy or decompress (if archived,
e.g., in a .zip file) the script file — and any other required files that you may
have received — into <resources>/scripts or a subdirectory of it.
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After having installed a new script file, TEXworks needs to become aware
of it. It automatically scans for all scripts during start-up, so you could close
all TEXworks windows and restart the application. An alternative is provided
by the Scripts→Scripting TEXworks→Reload Script List menu item
which rescans all scripts without otherwise interfering with the program.
You can also disable scripts (or whole directories of scripts) if you want
to. This can be useful if you do not need some scripts for some time and do
not want them to clutter the Scripts menu, but do not want to uninstall
them entirely. Or if you want to prevent hook scripts from being run automatically. To do this, open the “Manage Scripts” dialogue with the Scripts
→Scripting TEXworks→Manage Scripts menu item. Simply uncheck
the script you want to disable and it won’t bother you again.

6.3

Using Scripts

Using scripts is simple. Hook scripts are used automatically — you don’t
need to do anything. Standalone scripts show up in the Scripts menu or one
of its submenus. If you cannot find a script you are looking for, or if you find
a script you do not know the purpose of, you can use the “Manage Scripts”
dialogue to get additional information (like the author, a brief description,
etc.) about it.
Some scripts will require to run other programs on your system. One
example for this is a script that opens the pdf in the system’s default previewer, e.g., for printing. Since running arbitrary commands can in some
situations be particularly dangerous, this functionality is disabled by default. You will notice this when a dialogue pops up informing you of an
error in the script, or a similar message is displayed in the status bar. To
enable scripts to execute system commands, open the preferences dialogue
via Edit→Preferences. . . . There, go to the “Scripts” tab and check the
“Allow scripts to run system commands” option. If you want to disable this
function again later just uncheck the option. Note that this option applies
equally to all scripts — there is currently no way to allow command execution
only for some scripts.

A
Annexes

A.1

Keyboard shortcuts

The use of keyboard shortcuts greatly facilitates typing in and the management of the source and the preview. Their use is much more effective
than the use of buttons for frequently-used actions.
Below, you’ll find the shortcuts for source and preview windows. Note
that on Mac OS X, Ctrl actually refers to the Command key, which is the
usual modifier for keyboard shortcuts. Although the keyboard shortcuts are
specified with Ctrl, this will appear as the Command-key symbol in menus.
(To refer to the actual Control key on the Mac, the shortcut file should use
the name Meta).
Note that the shortcuts listed below are the default shortcuts for the English interface of TEXworks. Different languages may use different shortcuts.
All the shortcuts can be redefined either to create new shortcuts or to
modify the existing ones to match personal uses or change shortcuts not
adapted to one particular keyboard layout. The list of possible actions to
associate with shortcuts is given after the predefined shortcuts.
To define your own shortcuts, put a file named shortcuts.ini in the
<resources>/configuration folder, next to auto-indent-patterns.txt,
delimiter-pairs.txt, . . . , texworks-config.txt.
For example, this file could contain:
actionHard_Wrap = Shift+F3
actionLast_Page = Ctrl+End
actionFirst_Page = Ctrl+Home
actionWrap_Lines = F3
actionLine_Numbers = F4
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actionBalance_Delimiters = F9

The first line says that using Shift ⇑ F3 opens the hardwrap dialog box
in the source window; the second ( Ctrl End ) brings you to the last page
and Ctrl Home (third line) to the first page; with F3 you wrap/unwrap
lines in the source, with F4 you show/hide line numbers and with F9 you
select the text between corresponding delimiters in the source.

A.1.1

Predefined shortcuts

For working in the source window:
Shortcut

Action

Ctrl+’
Ctrl+=
Ctrl+A
Ctrl+Alt+S
Ctrl+B
Ctrl+C
Ctrl+E
Ctrl+F
Ctrl+G
Ctrl+H
Ctrl+L
Ctrl+N
Ctrl+O
Ctrl+Q
Ctrl+R
Ctrl+S
Ctrl+Shift+E
Ctrl+Shift+N
Ctrl+Shift+R
Ctrl+Shift+S
Ctrl+Shift+Z
Ctrl+Shift+[
Ctrl+Shift+]
Ctrl+T
Ctrl+V
Ctrl+W
Ctrl+X

Go to Preview
Show Selection
Select All
Save All
Balance Delimiters
Copy
Copy to Find
Find...
Find Again
Find Selection
Go to Line...
New
Open...
Quit TeXworks
Replace...
Save
Copy to Replace
New from Template...
Replace Again
Save As...
Redo
Uncomment
Comment
Typeset
Paste
Close
Cut
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Shortcut

Action

Ctrl+Z
Ctrl+[
Ctrl+\
Ctrl+]

Undo
Unindent
Hide Output Panel
Indent

Moving the cursor (hold Shift ⇑ to select):
Shortcut

Action

→
Ctrl+→
←
Ctrl+←
↑
↓
PgUp
PgDown
Home
Ctrl+Home
End
Ctrl+End

1 character right
1 word right
1 character left
1 word left
1 line up
1 line down
1 screen up
1 screen down
Begin of line
Begin of document
End of line
End of document

For working in the preview window:
Shortcut

Action

Ctrl+’
Ctrl++
Ctrl+Ctrl+1
Ctrl+2
Ctrl+3
Ctrl+Backspace
Ctrl+C
Ctrl+F
Ctrl+G
Ctrl+J
Ctrl+N
Ctrl+O
Ctrl+Q

Go to Source
Zoom In
Zoom Out
Actual Size
Fit to Width
Fit to Window
Clear
Copy
Find...
Find Again
Go to Page...
New
Open...
Quit TeXworks
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Shortcut

Action

Ctrl+Shift+F
Ctrl+Shift+N
Ctrl+Shift+Z
Ctrl+T
Ctrl+V
Ctrl+W
Ctrl+X
Ctrl+Z
End
Home
PgDown
PgUp

Full Screen
New from Template...
Redo
Typeset
Paste
Close
Cut
Undo
Last Page
First Page
Next Page
Previous Page

Actions listed alphabetically

actionAbout_Scripts
actionAbout_TW
actionActual_Size
actionApply_to_Selection
actionAutoIndent_None
actionAuto_Follow_Focus
actionBalance_Delimiters
actionClear
actionClose
actionComment
actionCopy
actionCopy_to_Find
actionCopy_to_Replace
actionCut
actionFind
actionFind_Again
actionFind_Selection
actionFirst_Page
actionFit_to_Width
actionFit_to_Window
actionFont
actionFull_Screen
actionGoToHomePage

actionPaste
actionPlace_on_Left
actionPlace_on_Right
actionPreferences
actionPrevious_Page
actionQuit_TeXworks
actionRedo
actionRemove_Aux_Files
actionReplace
actionReplace_Again
actionRevert_to_Saved
actionSave
actionSave_All
actionSave_As
actionScroll
actionSelect_All
actionSelect_Image
actionSelect_Text
actionShow_Hide_Console
actionShow_Scripts_Folder
actionShow_Selection
actionSide_by_Side
actionSmartQuotes_None
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actionGo_to_Line
actionGo_to_Page
actionGo_to_Preview
actionGo_to_Source
actionHard_Wrap
actionIndent
actionLast_Page
actionLine_Numbers
actionMagnify
actionManage_Scripts
actionNew
actionNew_from_Template
actionNext_Page
actionNone
actionOpen
actionOpen_Recent
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actionStack
actionSyntaxColoring_None
actionTile
actionTo_Lowercase
actionTo_Uppercase
actionToggle_Case
actionTypeset
actionUncomment
actionUndo
actionUnindent
actionUpdate_Scripts
actionWrap_Lines
actionWriteToMailingList
actionZoom_In
actionZoom_Out

Actions listed by menu

For the source window:

actionBalance_Delimiters
actionClear
actionCopy
actionCut
actionNone
actionPaste
actionPreferences
actionClose
actionNew
actionNew_from_Template
actionOpen
actionOpen_Recent
actionQuit_TeXworks
actionApply_to_Selection
actionAutoIndent_None
actionComment

Edit
actionRedo
actionSelect_All
actionTo_Lowercase
actionTo_Uppercase
actionToggle_Case
actionUndo
File
actionRemove_Aux_Files
actionRevert_to_Saved
actionSave
actionSave_All
actionSave_As
Format
actionLine_Numbers
actionSmartQuotes_None
actionSyntaxColoring_None
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actionFont
actionHard_Wrap
actionIndent
actionAbout_TW
actionGoToHomePage
actionAbout_Scripts
actionManage_Scripts
actionCopy_to_Find
actionCopy_to_Replace
actionFind
actionFind_Again
actionFind_Selection
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actionUncomment
actionUnindent
actionWrap_Lines
Help
actionWriteToMailingList
Scripts
actionShow_Scripts_Folder
actionUpdate_Scripts
Search
actionGo_to_Line
actionReplace
actionReplace_Again
actionShow_Selection
Typeset

actionTypeset
actionAuto_Follow_Focus
actionGo_to_Preview
actionPlace_on_Left
actionPlace_on_Right

Window
actionShow_Hide_Console
actionSide_by_Side
actionStack
actionTile

For the preview window:

actionClear
actionCopy
actionCut
actionPaste
actionClose
actionNew
actionNew_from_Template
actionAbout_TW
actionGoToHomePage

Edit
actionPreferences
actionRedo
actionUndo
File
actionOpen
actionOpen_Recent
actionQuit_TeXworks
Help
actionWriteToMailingList
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actionAbout_Scripts
actionManage_Scripts

Scripts
actionShow_Scripts_Folder
actionUpdate_Scripts

actionFind

Search
actionFind_Again
Typeset

actionTypeset
actionActual_Size
actionFirst_Page
actionFit_to_Width
actionFit_to_Window
actionFull_Screen
actionGo_to_Page
actionGo_to_Source
actionPlace_on_Left
actionPlace_on_Right

A.1.4

View
actionLast_Page
actionNext_Page
actionPrevious_Page
actionZoom_In
actionZoom_Out
Window
actionSide_by_Side
actionStack
actionTile

Other actions

In addition to the static actions listed above, there are also actions
for scripts. These are dynamic in nature, as they are created on-the-fly
for the available scripts (which may change when you install scripts, remove them, or change some settings). All of these actions are of the form
Script:␣<script_title>, where <script_title> must be replaced appropriately. If you have a script that shows up as My Script, for example, the
corresponding action would be named Script:␣My␣Script.

A.2

Regular expressions

As TEXworks is built on Qt4, the available regular expressions — which
are often referred to as regexp — are a subset of those found in Qt4. See
the site of Qt4 1 for more information. It is possible to find other information
about regexps on the net 2 or from books. But pay attention that not all sys1. http://doc.trolltech.com/4.4/qregexp.html#details – this section is based on
the information provided there
2. see, for example, Wikipedia
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tems (programming languages, editors, . . . ) use the same set of instructions;
there is no “standard set”, unfortunately.

A.2.1

Introduction

When searching and replacing, one has to define the text to be found.
This can be the text itself (e.g., “Abracadabra”), but often it is necessary
to define the strings in a more generic and powerful way to avoid repeating
the same operation many times with only small changes from one time to
the next; if, for example, one wants to replace sequences of the letter a by
ones of the letter o, but only those sequences of 3, 4, 5, 6 or 7 a; this would
require repeating (and slightly adjusting) the find and replace procedure 5
times. Another example: replace all vowels by § — again, this would take 5
replace operations.
Here come the regular expressions!
A simple character (a or 9) represents itself. But a set of characters can
be defined: [aeiou] will match any vowel, [abcdef] the letters a, b, c, d, e,
and f ; this last set can be shortened as [a-f] using “-” between the two ends
of the range. This can even be combined: [a-zA-Z0-9] will match all letters
and all numbers.
To define a complementary set 3 , one uses “ˆ”: the caret negates the
character set if it occurs as the first character, i.e. immediately after the
opening square bracket. [ˆabc] matches anything except a, b, c.

A.2.2

Codes to represent special sets

When using regexps, one very often has to create a search expession which
represent other strings in a generic way. If you are looking for a string which
represents an email address, for example, the letters and symbols will vary;
still, you could search for any string which corresponds to the structure of an
email address (<text>@<text>.<text> – roughly). To facilitate this, there
are abbreviations to represent letters, figures, symbols, . . .
These codes replace and facilitate the definition of sets; for example, to
instead of manually defining the set of digits [0-9], one can use “\d”. The
following table lists the replacement codes. 4
3. A set of characters that are not allowed to occur for this regular expression to match
the text
4. simplified from Qt4 at trolltech, see note 1
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Element

Meaning

c

Any character represents itself unless it has a special regexp
meaning. Thus c matches the character c.
A special character that follows a backslash matches the character itself except where mentioned below. For example, if you
wished to match a literal caret at the beginning of a string you
would write “\^”.
This matches the ASCII line feed character (LF, Unix newline,
used in TEXworks).
This matches the ASCII carriage return character (CR).
This matches the ASCII horizontal tab character (HT).
This matches the ASCII vertical tab character (VT; almost
never used).
This matches the Unicode character corresponding to the hexadecimal number hhhh (between 0x0000 and 0xFFFF). \0ooo
(i.e., zero-ooo) matches the ASCII/Latin-1 character corresponding to the octal number ooo (between 0 and 0377).
This matches any character (including newline). So if you want
to match the dot character iteself, you have to escape it with
“\.”.
This matches a digit.
This matches a non-digit.
This matches a white space.
This matches a non-white space.
This matches a word character or “_”).
This matches a non-word character.
The n-th back-reference, e.g. \1, \2, etc.; used in the replacement string with capturing patterns — see below

\c

\n
\r
\t
\v
\xhhhh

. (dot)

\d
\D
\s
\S
\w
\W
\1, . . .

Using these abbreviations is better than describing the set, because the
abbreviations remain valid in different alphabets.
Pay attention that the end of line is often taken as a white space. Under
TEXworks the end of line is referred to by “\n”.

A.2.3

Repetition

One doesn’t work only on single letters, digits, symbols; most of the time,
these are repeated (e.g., a number is a repetition of digits and symbols – in
the right order).
To show the number of repetitions, one uses a so called “quantifier”:
a{1,1} means at least one and only one a, a{3,7} means between at least
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3 and at most 7 a; {1,1} is redundant, of course, so a{1,1} = a.
This can be combined with the set notation: [0-9]{1,2} will correspond
to at least one digit and at most two, the integer numbers between 0 and 99.
But this will match any group of 1 or 2 digits within any arbitrary string
(which may have a lot of text before and after the integer); if we want this
to match only if the whole string constists entirely of 1 or 2 digits (without
any other characters preceding or following them), we can write the regular
expression as ˆ[0-9]{1,2}$; here, ˆ says that any match must start at the
first character of the string, while the $ says that any match must end at
the last character of the string, so the string can only be comprised of one
or two digits (ˆ and $ are so-called “assertions” — more on them later).
Here is a table of quantifiers. 5 E represents an arbitrary expression (letter, abbreviation, set).
E{n,m}
E{n}
E{n,}
E{,m}
E?

E+
E*

A.2.4

Matches at least n occurrences of the expression and at most
m occurrences of the expression.
Matches exactly n occurrences of the expression. This is the
same E{n,n} or as repeating the expression n times.
Matches at least n occurrences of the expression.
Matches at most m occurrences of the expression.
Matches zero or one occurrence of E. This quantifier effectively
means the expression is optional (it may be present, but doesn’t
have to). It is the same as E{0,1}.
Matches one or more occurrences of E. This is the same as
E{1,}.
Matches zero or more occurrences of E. This is the same as
E{0,}. Beware, the * quantifier is often used by mistake instead of the + quantifier. Since it matches zero or more occurrences, it will match even if the expression is not present in the
string.

Alternatives and assertions

When searching, it is often necessary to search for alternatives, e.g., apple,
pear, or cherry, but not pineapple. To separate the alternatives, one uses |:
apple|pear|cherry. But this will not prevent to find pineapple, so we have to
specify that apple should be standalone, a whole word (as is often called in
the search dialog boxes).
To specify that a string should be considered standalone, we specify that it
is surrounded by word separators/boundaries (begin/end of sentence, space),
5. simplified from Qt4 at trolltech, see note 1
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like \bapple\b. For our alternatives example we will group them by parentheses and add the boundaries \b(apple|pear|cherry)\b. Apart from \b
we have already seen ˆ and $ which mark the boundaries of the whole string.
Here a table of the “assertions” which do not correspond to actual characters and will never be part of the result of a search. 6
^
$
\b
\B
(?=E)
(?!E)

The caret signifies the beginning of the string. If you wish to
match a literal ˆ, you must escape it by writing \^
The dollar signifies the end of the string. If you wish to match
a literal $, you must escape it by writing \$
A word boundary.
A non-word boundary. This assertion is true wherever \b is
false.
Positive lookahead. This assertion is true if the expression E
matches at this point.
Negative lookahead. This assertion is true if the expression E
does not match at this point.

Notice the different meanings of ˆ as assertion and as negation inside a
set!

A.2.5

Final notes

Using rexexp is very powerful, but also quite dangerous; you could change
your text at unseen places and sometimes reverting to the previous situation
is not possible entirely. If you immediately see the error, you can try Ctrl
Z .
Showing how to exploit the full power of regexp would require much more
than this extremely short summary; in fact it would require a full manual on
it own.
Also note that there are some limits in the implementation of regexps in
TEXworks; in particular, the assertions (ˆ and $) only consider the whole file,
and there are no look-behind assertions.
Finally, do not forget to “tick” the regexp option when using them in the
Find and Replace dialogs and to un-tick the option when not using regexps.

A.3

Roots for completion

We give here the keywords for auto-completion as they are supplied by
TEXworks. They are given in the files tw-basic.txt, tw-context.txt (ini6. simplified from Qt4 at trolltech, see note 1
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tially empty) and tw-latex.txt in the <resource>\completion folder.
We give them in three columns: the first two show the keywords, the
third the (LA)TEX code produced. In some cases there is only the code, this
means that you can start to enter the (LA)TEX code and try to complete it
with  .
During completion, the system inserts line feeds and puts the cursor at
the first place where one has to enter information to complete the typing. To
represent the line feeds we used R and I for the input point.
It is possible to see that the keywords have some pattern. The mathematical variables have a keyword starting with x, when they are in a mathematical environment; when they are used alone in the text you add d in
front. For example, xa and dxa give \alpha, if there is a capital there
is a c, as xo for \omega and xco for \Omega. The keywords for environments start with b: bali for \begin{align} (b is a mnemonic for \begin).
When the environment has possible options, there is one or more o added
to the base name: bminp gives \begin{minipage}{}... while bminpo gives
\begin{minipage}[]{}....
Keywords defined in tw-basic.txt (defined in TEX):
xa
xb

\xa
\xb
\bsk

xch
xd
xcd
xe
xet
xg
xcg

\xch
\xd
\xcd
\xe
\xet
\xg
\xcg

xio
xl
xcl

\xio
\xl
\xcl
\msk

xm

\xm

xn

\xn

\alpha
\beta
\bigskip
\bigskipR
\chi
\delta
\Delta
\epsilon
\eta
\gamma
\Gamma
\hskip
\indent
\input
\iota
\lambda
\Lambda
\medskip
\medskipR
\mu
\noindent
\nu
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xo
xco

\xo
\xco

xcph
xph
xp
xcp
xcps
xps
xr

\xcph
\xph
\xp
\xcp
\xcps
\xps
\xr

xs
xcs

\xs
\xcs

xt
tex

\ssk
\xt
\tex

texs

\texs

xth
xcth
xu
xcu
xve
xvph
xvp
xvr
xvs
xvth

\xth
\xcth
\xu
\xcu
\xve
\xvph
\xvp
\xvr
\xvs
\xvth

xcx
xx
xz

\xcx
\xx
\xz

\omega
\Omega
\par
\Phi
\phi
\pi
\Pi
\Psi
\psi
\rho
\scriptsize
\sigma
\Sigma
\smallskipR
\smallskipR
\tau
\TeX
\TeX
\TeX\
\TeX\
\theta
\Theta
\upsilon
\Upsilon
\varepsilon
\varphi
\varpi
\varrho
\varsigma
\vartheta
\vskip
\Xi
\xi
\zeta

Keywords defined in tw-latex.txt (defined in LATEX):
ncol
dd
dxa
dxb

\ncol
\dd
\dxa
\dxb

&
\( I \)•
\(\alpha\)
\(\beta\)

A. Annexes
dxch
dxd
dxcd
dxe
dxet
dxg
dxcg
dxio
dxl
dxcl
dxm
dxn
dxo
dxco
dxcph
dxph
dxp
dxcp
dxcps
dxps
dxr
dxs
dxt
dxth
dxcth
dxu
dxcu
dxve
dxvph
dxvp
dxvr
dxvs
dxvth
dxx
dxcx
dxz

45
\dxch
\dxd
\dxcd
\dxe
\dxet
\dxg
\dxcg
\dxio
\dxl
\dxcl
\dxm
\dxn
\dxo
\dxco
\dxcph
\dxph
\dxp
\dxcp
\dxcps
\dxps
\dxr
\dxs
\dxcs
\dxt
\dxth
\dxcth
\dxu
\dxcu
\dxve
\dxvph
\dxvp
\dxvr
\dxvs
\dxvth
\dxx
\dxcx
\dxz
\adc

adcount
\adl

\(\chi\)
\(\delta\)
\(\Delta\)
\(\epsilon\)
\(\eta\)
\(\gamma\)
\(\Gamma\)
\(\iota\)
\(\lambda\)
\(\Lambda\)
\(\mu\)
\(\nu\)
\(\omega\)
\(\Omega\)
\(\Phi\)
\(\phi\)
\(\pi\)
\(\Pi\)
\(\Psi\)
\(\psi\)
\(\rho\)
\(\sigma\)
\(\Sigma\)
\(\tau\)
\(\theta\)
\(\Theta\)
\(\upsilon\)
\(\Upsilon\)
\(\varepsilon\)
\(\varphi\)
\(\varpi\)
\(\varrho\)
\(\varsigma\)
\(\vartheta\)
\(\xi\)
\(\Xi\)
\(\zeta\)
\addtocounter{I}{•}
\addtocounter{I}{•}
\addtocounter{I}{•}R
\addtolength{I}{•}
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adlen

babs
balis
baliats
baliat
baliedat
baliedato
balied
bali
bapp
barr
bbmat
bcase
bcent
bcenum
bcenumo
bcitem
bcitemo
bdes
benu
benuo
beqns
beqn
bequs
bequ
bfig
bfigo
bflaligs
bflalig
bfll
bflr
bgaths
bgathed
bgathedo
bgath
bite
biteo
blett
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\addtolength{I}{•}
\addtolength{I}{•}R
\author{I}R
\begin{
\babs
\begin{abstract}RIR\end{abstract}•
\balis
\begin{align*}RIR\end{align*}•
\baliats
\begin{alignat*}{I}R•R\end{alignat*}•
\baliat
\begin{alignat}{I}R•R\end{alignat}•
\baliedat \begin{alignedat}RIR\end{alignedat}•
\baliedato \begin{alignedat}[I]R•R\end{alignedat}•
\balied
\begin{aligned}{I}R•R\end{aligned}•
\bali
\begin{align}RIR\end{align}•
\bapp
\begin{appendix}RIR\end{appendix}•
\begin{array}RIR\end{array}•
\bbmat
\begin{bmatrix}RIR\end{bmatrix}•
\bcase
\begin{cases}RIR\end{cases}•
\bcent
\begin{center}RIR\end{center}•
\bcenum
\begin{compactenum}R\itemRIR\end{compactenum}•
\bcenumo \begin{compactenum}[I]R\itemR•R\end{compactenum}•
\bcitem
\begin{compactitem}R\itemRIR\end{compactitem}•
\bcitemo \begin{compactitem}[I]R\itemR•R\end{compactitem}•
\bdes
\begin{description}R\item[I]R•R\end{description}•
\benu
\begin{enumerate}R\itemRIR\end{enumerate}•
\benuo
\begin{enumerate}[I]R\itemR•R\end{enumerate}•
\beqns
\begin{eqnarray*}RIR\end{eqnarray*}•
\beqn
\begin{eqnarray}RIR\end{eqnarray}•
\bequs
\begin{equation*}RIR\end{equation*}•
\bequ
\begin{equation}RIR\end{equation}•
\bfig
\begin{figure}RIR\end{figure}•
\bfigo
\begin{figure}[I]R•R\end{figure}•
\bflaligs
\begin{flalign*}RIR\end{flalign*}•
\bflalig
\begin{flalign}RIR\end{flalign}•
\bfll
\begin{flushleft}RIR\end{flushleft}•
\bflr
\begin{flushright}RIR\end{flushright}•
\bgaths
\begin{gather*}RIR\end{gather*}•
\bgathed \begin{gathered}RIR\end{gathered}•
\bgathedo \begin{gathered}[I]R•R\end{gathered}•
\bgath
\begin{gather}RIR\end{gather}•
\bite
\begin{itemize}R\itemRIR\end{itemize}•
\biteo
\begin{itemize}[I]R\itemR•R\end{itemize}•
\blett
\begin{letter}{I}R•R\end{letter}•
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bminpo
bminp
bmults
bmult
bpict
bpmat
bquot
bquo
bsplit
bsubeq
btabb
btbls
btabls
btablso
btblso
btbl
btabl
btblo
btablo
btabs
btabx
btab
bbib
bindex
btheo
btitpg
btrivl
bvarw
bverb
bvers
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\blist
\bminpo
\bminp
\bmults
\bmult
\bpict
\bpmat
\bquot
\bquo
\bsplit
\bsubeq
\btabb
\btbls
\btabls
\btablso
\btblso
\btbl
\btabl
\btblo
\btablo
\btabs
\btabx
\btab
\bbib
\bindex
\btheo
\btitpg
\btrivl
\bvarw
\bverb
\bvers

bfd
bibitemo
bibitem
bibstyle
biblio

\bibstyle

\begin{list}{I}{•}R\itemR•R\end{list}•
\begin{minipage}[I]{•}R•R\end{minipage}•
\begin{minipage}{I}R•R\end{minipage}•
\begin{multline*}RIR\end{multline*}•
\begin{multline}RIR\end{multline}•
\begin{picture}RIR\end{picture}•
\begin{pmatrix}RIR\end{pmatrix}•
\begin{quotation}RIR\end{quotation}•
\begin{quote}RIR\end{quote}•
\begin{split}RIR\end{split}•
\begin{subequations}RIR\end{subequations}•
\begin{tabbing}RIR\end{tabbing}•
\begin{table*}RIR\end{table*}•
\begin{table*}RIR\end{table*}•
\begin{table*}[I]R•R\end{table*}•
\begin{table*}[I]R•R\end{table*}•
\begin{table}RIR\end{table}•
\begin{table}RIR\end{table}•
\begin{table}[I]R•R\end{table}•
\begin{table}[I]R•R\end{table}•
\begin{tabular*}{I}{•}R•R\end{tabular*}•
\begin{tabularx}{I}{•}R•R\end{tabularx}•
\begin{tabular}{I}R•R\end{tabular}•
\begin{thebibliography}{I}R\bibitem{•}R•R\end{thebibliography}•
\begin{theindex}RIR\end{theindex}•
\begin{theorem}RIR\end{theorem}•
\begin{titlepage}RIR\end{titlepage}•
\begin{trivlist}RIR\end{trivlist}•
\begin{varwidth}{I}R•R\end{varwidth}•
\begin{verbatim}RIR\end{verbatim}•
\begin{verse}RIR\end{verse}•
\bfseries
\bfseries
\bibitem[I]{•}R•
\bibitem[I]{•}R•
\bibitem{I}R•
\bibitem{I}R•
\bibliographystyle{I}
\bibliography{I}
\bibliography{I}
\bottomruleR
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center

chap

cmidr
cmidro

emd
em

fbox

foot
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\bottomruleR
\boxed{I}
\caption{I}R
\cdots
\centering
\centering
\chapter{I}
\chapter{I}R
\citep{I}
\citet{I}
\cite{I}
\cline{I}
\cmidrule(I){•}
\cmidrule(I){•}
\cmidrule[I](•){•}
\cmidrule[I](•){•}
\date{I}R
\ddddot{I}
\dddot{I}
\ddots
\ddot{I}
\documentclass[I]{•}R
\documentclass{I}R
\dots
\dotsb
\dotsc
\dotsi
\dotsm
\dotso
\em
\emph{I}
\emph{I}
\end{I}R
\eqref{I}
\fboxrule{I}
\fboxsep{I}
\fbox{I}
\fbox{I}
\footnotesize
\footnote{I}
\footnote{I}
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frac
fboxoo

\fboxoo

fboxo
geometry

\fboxo

hw
href

incgo

incg

ito
itd
lbl

\lbl

latex

\latex

latexs

\latexs

latexe
latexes

\latexe
\latexes

listf

\listf

\frac{I}{•}
\frac{I}{•}
\framebox[I][•]{•}
\framebox[I][•]{•}
\framebox[I]{•}
\framebox[I]{•}
\geometry{•}
\geometry{•}
\headwidth
\headwidth
\hlineR
\href{I}{•}
\href{I}{•}
\hspace*{I}
\hspace{I}
\includegraphics[I]{•}R
\includegraphics[I]{•}R
\includegraphics{I}R
\includegraphics{I}R
\include{I}R
\intertext{I}
\itemRI
\item[I]R•
\item[I]R•
\itshape
\itshape
\label{I}
\label{I}
\Large
\large
\LaTeX
\LaTeX
\LaTeX\
\LaTeX\
\LaTeXe
\LaTeXe
\LaTeXe\
\LaTeXe\
\ldots
\listoffiguresR
\listoffiguresR
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listt
mboxoo

\listt
\mboxoo

mboxo
mpar

\mboxo
\mpar

mbf
mcal

\mbf
\mcal

mit

\mit

mnorm

\mnorm

mrm
msf

\mrm
\msf

mtt
mbox

\mtt

mdd
midr
multc
multic
nct
newct

ncmoo
newcoo
newco
ncmo

\multc

\listoftablesR
\listoftablesR
\makebox[I][•]{•}
\makebox[I][•]{•}
\makebox[I]{•}
\makebox[I]{•}
\marginpar{I}
\marginpar{I}
\mathbf{I}
\mathbf{I}
\mathcal{I}
\mathcal{I}
\mathit{I}
\mathit{I}
\mathnormal{I}
\mathnormal{I}
\mathrm{I}
\mathrm{I}
\mathsf{I}
\mathsf{I}
\mathtt{I}
\mathtt{I}
\mbox{I}
\mbox{I}
\mdseries
\mdseries
\midruleR
\midruleR
\multicolumn{I}{•}{•}
\multicolumn{I}{•}{•}
\multicolumn{I}{•}{•}
\newcolumntype{I}{•}
\newcolumntype{I}{•}
\newcolumntype{I}{•}
\newcommand{I}[•][•]{•}R
\newcommand{I}[•][•]{•}R
\newcommand{I}[•][•]{•}R
\newcommand{I}[•]{•}R
\newcommand{I}[•]{•}R
\newcommand{I}[•]{•}R
\newcommand{I}{•}R
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ncm
newc
nenvoo
neweoo
nenvo
neweo
nenv
newe
nlen
newlen
newlin
nline
npg
newpg

\npg

pgref
pgs
pars

paro
par
pboxo

\pboxo

parboxo
parbox
\pbox

\newcommand{I}{•}R
\newcommand{I}{•}R
\newenvironment{I}[•][•]{•}{•}R
\newenvironment{I}[•][•]{•}{•}R
\newenvironment{I}[•][•]{•}{•}R
\newenvironment{I}[•]{•}{•}R
\newenvironment{I}[•]{•}{•}R
\newenvironment{I}{•}{•}R
\newenvironment{I}{•}{•}R
\newenvironment{I}{•}{•}R
\newlength{I}R
\newlength{I}R
\newlength{I}R
\newlineR
\newlineR
\newlineR
\newpageR
\newpageR
\newpageR
\newtheorem{I}[•]{•}R
\newtheorem{I}{•}R
\newtheorem{I}{•}[•]R
\nocite{I}
\normalsize
\pagebreakR
\pageref{I}
\pageref{I}
\pagestyle{I}R
\pagestyle{I}R
\paragraph*{I}R
\paragraph*{I}R
\paragraph[I]{•}R
\paragraph[I]{•}R
\paragraph{I}R
\paragraph{I}R
\parbox[I]{•}{•}
\parbox[I]{•}{•}
\parbox[I]{•}{•}
\parbox{I}{•}
\parbox{I}{•}
\parbox{I}{•}
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pbox
rboxoo

\rboxoo

rboxo

\rboxo

rbox
ref

\rbox

rnewcoo
rncmoo
rnewco
rncmo
rncm
rnewc

rmc

scd
secs
seco

sec
hw2tw
sfd
sld
sqrto
sqrt
stcount
spars

\sqrto
\sqrt
\spars

\pbox{I}{•}
\pbox{#INS}{•}
\raisebox{I}[•][•]{•}
\raisebox{I}[•][•]{•}
\raisebox{I}[•]{•}
\raisebox{I}[•]{•}
\raisebox{I}{•}
\raisebox{I}{•}
\ref{I}
\ref{I}
\renewcommand{I}[•][•]{•}R
\renewcommand{I}[•][•]{•}R
\renewcommand{I}[•][•]{•}R
\renewcommand{I}[•]{•}R
\renewcommand{I}[•]{•}R
\renewcommand{I}[•]{•}R
\renewcommand{I}{•}R
\renewcommand{I}{•}R
\renewcommand{I}{•}R
\rmfamily
\rmfamily
\rule[I]{•}{•}
\rule{I}{•}
\scshape
\scshape
\section*{I}R
\section*{I}R
\section[I]{•}R
\section[I]{•}R
\section{I}R
\section{I}R
\setlength{I}{•}
\setlength{\headwidth}{\textwidth}R
\sffamily
\sffamily
\slshape
\slshape
\sqrt[I]{•}
\sqrt{I}
\stepcounter{I}R
\subparagraph*{I}
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sparo

\sparo

spar
ssecs

\spar
\ssecs

sseco

\sseco

ssec

\ssec

sssecs

\sssecs
\ssseco

ssseco
sssec

\sssec

toc
\toc
tableofcontents
tilde
bf

\tilde
\bf

---it

\it

sc

\rm
\sc

sf

\sf

sl
tt

\sl
\tt

up
tw

\up
\tw

\subparagraph*{I}
\subparagraph[I]{•}
\subparagraph[I]{•}
\subparagraph{I}
\subparagraph{I}
\subsection*{I}R
\subsection*{I}R
\subsection[I]{•}R
\subsection[I]{•}R
\subsection{I}R
\subsection{I}R
\subsubsection*{I}R
\subsubsection*{I}R
\subsubsection[I][•]R
\subsubsection[I][•]R
\subsubsection[I]{•}R
\subsubsection{I}R
\subsubsection{I}R
\tableofcontentsR
\tableofcontentsR
\tableofcontentsR
\textasciitilde
\textbf{I}
\textbf{I}
\textemdash\
\textendash\
\textit{I}
\textit{I}
\textrm{I}
\textsc{I}
\textsc{I}
\textsf{I}
\textsf{I}
\textsl{I}
\textsl{I}
\texttt{I}
\texttt{I}
\textup{I}
\textup{I}
\textwidth
\textwidth
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ttd
upd
url

usepo
usep
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\text{I}
\thanks{I}R
\title{I}R
\topruleR
\topruleR
\ttfamily
\ttfamily
\upshape
\upshape
\url{I}
\url{I}
\usepackage[I]{•}R
\usepackage[I]{•}R
\usepackage{I}R
\usepackage{I}R
\vdots
\vspace*{I}R
\vspace{I}R
{abstract}RIR\end{abstract}•
{align*}RIR\end{align*}•
{alignat*}{I}R•R\end{alignat*}•
{alignat}{I}R•R\end{alignat}•
{alignedat}{I}R•R\end{alignedat}•
{aligned}RIR\end{aligned}•
{aligned}[I]R•R\end{aligned}•
{align}RIR\end{align}•
{appendix}RIR\end{appendix}•
{array}RIR\end{array}•
{bmatrix}RIR\end{bmatrix}•
{cases}RIR\end{cases}•
{center}RIR\end{center}•
{compactenum}R\itemRIR\end{compactenum}•
{compactenum}[I]R\itemR•R\end{compactenum}•
{compactitem}R\itemRIR\end{compactitem}•
{compactitem}[I]R\itemR•R\end{compactitem}•
{description}R\item[I]R•R\end{description}•
{enumerate}R\itemRIR\end{enumerate}•
{enumerate}[I]R\itemR•R\end{enumerate}•
{eqnarray*}RIR\end{eqnarray*}•
{eqnarray}RIR\end{eqnarray}•
{equation}RIR\end{equation}•
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{figure}RIR\end{figure}•
{figure}[I]R•R\end{figure}•
{flalign*}RIR\end{flalign*}•
{flalign}RIR\end{flalign}•
{flushleft}RIR\end{flushleft}•
{flushright}RIR\end{flushright}•
{gather*}RIR\end{gather*}•
{gathered}RIR\end{gathered}•
{gathered}[I]R•R\end{gathered}•
{gather}RIR\end{gather}•
{itemize}R\itemRIR\end{itemize}•
{itemize}[I]R\itemR•R\end{itemize}•
{letter}{I}R•R\end{letter}•
{list}{I}{•}R\itemR•R\end{list}•
{minipage}[I]{•}R•R\end{minipage}•
{minipage}{I}R•R\end{minipage}•
{multline*}RIR\end{multline*}•
{multline}RIR\end{multline}•
{picture}RIR\end{picture}•
{pmatrix}RIR\end{pmatrix}•
{quotation}RIR\end{quotation}•
{quote}RIR\end{quote}•
{split}RIR\end{split}•
{subequations}RIR\end{subequations}•
{tabbing}RIR\end{tabbing}•
{table*}RIR\end{table*}•
{table*}[I]R•R\end{table*}•
{table}RIR\end{table}•
{table}[I]R•R\end{table}•
{tabular*}{I}{•}R•R\end{tabular*}•
{tabularx}{I}{•}R•R\end{tabularx}•
{tabular}{I}R•R\end{tabular}•
{thebibliography}RIR\end{thebibliography}•
{theindex}RIR\end{theindex}•
{theorem}RIR\end{theorem}•
{titlepage}RIR\end{titlepage}•
{trivlist}RIR\end{trivlist}•
{varwidth}{I}R•R\end{varwidth}•
{verbatim}RIR\end{verbatim}•
{verse}RIR\end{verse}•
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There are also environment codes (above) without \begin{ (which is itself
a keyword); this allows to finish the environment name alone by  if one
started to input it manually.

A.4

Compiling TEXworks

A complete guide how to compile TEXworks is far beyond the scope of
this manual. However, most users should find precompiled versions suitable
for their system come either with their TEX distribution or their operating
system. If this is not the case, several precompiled versions can also be
downloaded from http://code.google.com/p/texworks/downloads/list.
Compiling TEXworks yourself is only necessary if your system is not (yet)
supported, if you want to always have the latest features (and bugs), or
generally want to help in improving TEXworks further. To this end, there
are some documents giving detailed instructions to compile TEXworks on
different machines.
http://code.google.com/p/texworks/wiki/Building
http://code.google.com/p/texworks/issues/detail?id=107
http://code.google.com/p/texworks/wiki/BuildingOnWindowsMinGW
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% !TeX
encoding, 24
program, 25
root, 17
spellcheck, 25
actions
alphabetically, 35
by menu, 36
auto-completion, 22
roots, 42
tw-basic.txt, 43
tw-latex.txt, 44
cleaning folder, 27
aux files, 27
comments, 12
compiling TEXworks, 56
completion, see auto-completion
configuration, 28
defaultbinpaths, 28
inipath, 28
libpath, 28
texworks-config.txt, 28
texworks-setup.ini, 28
texworks.ini, 28

console bar, 13
CTAN, 12
Ctrl+’, 11
Ctrl+T, 11
document
creation, 10
previewing, 11
source, 4
typesetting, 11
editing
change case, 20
comment, 21
indentation, 25
line numbers, 21
redo, 20
search/replace, 18
select a block, 21
tools, 20
uncomment, 21
undo, 20
editor, 4
font, 15
encoding, 24
latin1, 24
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utf-8, 12, 24
errors, 13
extension .tex, 11
files
format, 3
folder
hhomei/TeXworks, 8
.TeXworks, 7
.config/TUG, 7
auto-completion, 7
configuration, 7
dictionaries, 7
resource, 7
resource Mac, 8
templates, 7
TeXworks, 7
translations, 7
installation, 6
Linux, 7
Mac, 7
Windows, 6
interface, 9
Kew, Jonathan, 4
keyboard shortcuts, 32
actions, 32
predefined, 33
shortcuts.ini, 32
Knuth, Donald E., 3
Lamport, Leslie, 3
log, 11
METAFONT, 3
METAPOST, 4
output panel, 11
packages, 3, 12
PDF, 4
PostScript, 4
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preamble, 12
preferences, 15
preview, 9
preview window, 11
programme
default, 25
project, 16
regular expressions, 19, 38
alternatives/assertions, 41
introduction, 39
repetition, 40
sets, 39
scripts, 29
installing, 30
managing, 31
using, 31
writing, 29
search/replace, see editing
shortcuts, see keyboard shortcuts
source/editor, 9
spell-checking, 17
.aff files, 17
.dic files, 17
SyncTeX, 24
tags, 26
structure, 26
table of contents, 27
template, 16
TEX, 3
AMS-TEX, 3
LATEX, 3, 10
ConTeXt, 3
distribution, see TEX distribution
dvips, 4
LuaTeX, 4
pdftex, 4
XeTeX, 4
TEX distribution, 6
Linux, 6

Index
Mac, 6
MacTeX, 6
TeX Live, 6
Windows, 6
MikTeX, 6
TEXworks, 4
parameters, 15
toolbar, 9
typeset, 9
typing cursor, 13
utf-8, see encoding, utf-8
windows, 27
wrap lines
automatic, 26
hard, 26
WYSIWIG, 9
zoom, 27
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