[texworks] [EXT] Passing $synctexoption to Windows batch script?

Kyle Woodward kyle.woodward at gmail.com
Wed Feb 19 19:40:44 CET 2020


Scratch that, escaping `-synctex=1` to `-synctex^=1` in the Typesetting
dialog results in the same error.

Apologies for multiple messages.

On Wed, Feb 19, 2020 at 1:36 PM Kyle Woodward <kyle.woodward at gmail.com>
wrote:

> I suspect this would work, but I am passing $synctexoption as predefined
> in TeXworks [Edit > Preferences > Typesetting > Edit... > +]. I do not know
> of an option to redefine the internal parameters; I am also wary of
> redefining it, since it is passed to (e.g.) the predefined pdfLaTeX script.
>
> Regardless, this is IMO a better workaround than defining things in the
> batch script.
>
> On Wed, Feb 19, 2020 at 1:01 PM Philip Taylor <P.Taylor at rhul.ac.uk> wrote:
>
>> Kyle Woodward wrote:
>>
>> I am having trouble with a custom typesetting script (Windows batch). I
>> would like to pass $synctexoption to the script (in my case, `-synctex=1`).
>>
>>
>> Have you tried escaping the "=" sign with a caret/circumflex/"hat" ("^") ?
>> *Philip Taylor*
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://tug.org/pipermail/texworks/attachments/20200219/d09fc1d5/attachment.html>


More information about the texworks mailing list.