[texworks] Compiling with mingw32

Paul A Norman paul.a.norman at gmail.com
Mon May 24 05:42:48 CEST 2010

Thanks for that Stefan,

I was skim reading looking for the QTxml phrases, and missed the
general section on that.

Is it worth just including the batch file in the release (people could
edit it if they had not followed your path recommendations), and in
the texworks.pro Win32{ section any way? Wouldn't do anything if the
QT-4-a type files  are not found?

This is my first experience of building a cross platform  C++ project
on Windows, like many I've lived a very sheltered life so far, on
Windows my IDE/Compiler has only required me to nominate package and
library paths in the past, from drop-down boxes, and it has handled
all the rest :)

Ok so I  now successfully  have TWLuaPlugin.dll and
TWPythonPlugin.dll sitting in a newly made c:\texworks\plugins

I've done everything from scratch in the c:\texworks directory

mingw32-make clean
qmake -makefile -win32 TeXworks.pro

And I get lots of  this type of message

./obj/synctex_parser.o:synctex_parser.c:(.text+0x518): first defined here
./obj/synctex_parser.o:synctex_parser.c:(.text+0x534): multiple
definition of `synctex_node_h'

And then this vague message

collect2:ld returned 1 exit status
mingw32-make[1]: *** [release/TeXworks.exe] Error 1
mingw32-make[1]: Leaving directory `C:/texworks'
mingw32-make: *** [release] Error 2

I have tried to find a log file with the information in it, and then
I re-directed the out put of mingw32-make to a text file, but could
not find more specific detail on the ld type error. (" ld returned 1
exit status")


On 24 May 2010 02:15, Stefan Löffler <st.loeffler at gmail.com> wrote:
> Hi,
> Am 2010-05-23 13:02, schrieb Paul A Norman:
>> I went abck to the beginning and rebuilt the Lua5.1 but I still get
>> c:/mingw/bin/../lib/gcc/mingw32/4.4.0/../../../../mingw32/bin/ld.exe:
>> cannot find -lQtXml
>> My KDEDIRS env variable is set up and I've got kde directories
>> including c:\KDE\include;  in the path and c:\KDE\include\QtXml exists
>> with all of its files.
> OK, but the directories you mention are for include files needed by the
> compiler. Your error is created later by the linker. The file it is
> looking for is probably c:\KDE\lib\libQtXml.a. My guess is that you have
> a libQtXml4.a. In this case I'd suggest you follow the steps documented
> in the wiki page's Q&A under "When building TeXworks, I get an error
> about a missing Qt library of the form ".../ld.exe: cannot find
> -lQtScript". What's wrong?"
>> May be I have the wrong version of KDE?  I have run
>> C:\KDE\bin\designer.exe and it reports as QT 4.6
> 4.6 should work fine.
> Stefan

More information about the texworks mailing list