[texworks] Preferences on Mac OS X 10.6.2

Jonathan Kew jfkthame at googlemail.com
Tue Nov 24 21:57:24 CET 2009

On 24 Nov 2009, at 19:24, Helge Baumann wrote:

> Am 24.11.2009 um 07:31 schrieb Bruno Voisin:
>> On 24 nov. 2009, at 03:40, Helge Baumann wrote:
>>> deleting system font cache didn't help, same error in console ...
>>> Am 24.11.2009 um 03:33 schrieb Helge Baumann:
>>>> deleting my personal font cache (with Tinker Tool System)  didn't  
>>>> help, trying system font cache ...
>> Did you try also the command-line way described at <http://www.macworld.com/article/139383/2009/03/fontcacheclear.html 
>> >, logging in and back out afterwards (or even better rebooting)?
>> By any chance, have you also used Migration Assistant at some point  
>> in the past to move from one Mac with one version of OS X to  
>> another Mac with another version of OS X? I've seen all sorts of  
>> weird things happen here in my lab with colleagues using Migration  
>> Assistant, and ending up with a patchwork of preferences, caches  
>> and support files from different software versions, which  
>> invariably raises compatibility issues sooner or later.
>> I've been using OS X 10.6.2 for some time on two Macs, and not  
>> experiencing the problem you describe.
> Just deleted the font cache the suggested way, no difference :(
> And yes, I migrated from an 'old' MacBook UniBody 10.6 to my current  
> MacBookPro 10.6, but same OS versions and same users, including the  
> two with no problems. And I hadn't TeXWorks at this time.
> I can't believe that only 'my' TeXWorks has problems, and that no  
> other user or program has these problems.
> I think, that's why people don't like computers :)

Yes, issues like this can be really frustrating.

As I understand it so far:

* since updating to 10.6.2, TeXworks hangs when you try to open the  
Preferences dialog

* using a different user account *on the same machine*, the problem  
does not occur

This *strongly* suggests that the problem is triggered by something in  
your account's preferences or caches.

The Activity Monitor sample you provided of a "hang" shows clearly  
that it's trying to add the fonts to the popup menu:

   .. QComboBox::insertItems(int, QStringList const&)

and in the process, it's trying to do text layout:

   QLineEdit::setText(QString const&)
   .. QLineEditPrivate::updateTextLayout()
   .... QTextEngine::shapeTextMac(int) const
   ...... QFontEngineMacMulti::stringToCMapInternal
   ........ TTextLineLayout::ConstructGlyphRecordArray

but this is apparently hanging for you, whereas it doesn't for other  
people (or other users on your same machine).

The only plausible explanation I can think of is that there's some  
font-related data associated with your account that is confusing  
things. Do you run any kind of font-management software? Do you have  
fonts installed in ~/Library/Fonts? Do you have other "font libraries"  
enabled in FontBook?

All I can suggest -- though it sounds like you've already tried much  
of this -- is to:

(a) First, ensure that *everything* "special" related to fonts is  
disabled: any font managers, any user libraries, any fonts in ~/ 
Library/Fonts. Turn off the Automatic Font Activation option in Font  
Book / Preferences. Double-check, triple-check that NO fonts other  
than the standard ones in /System/Library/Fonts and /Library/Fonts are  
enabled. Do you have MS Office? Ensure its fonts are NOT installed/ 

(b) Second, clear every possible font-related cache and preference,  
and then restart the machine. If that still doesn't help, I'm at a loss.

Hmm, looks like other people have font-related hangs or crashes on  
10.6.2 as well, not related to TeXworks: see for example <http://discussions.apple.com/thread.jspa?threadID=2229872&tstart=0 
 >. Sounds like for some people, the only solution that's worked is to  
set up a new account or do a clean install. Ugh.


More information about the texworks mailing list