[texworks] Trying to build TeXworks on Xubuntu 8.10

Iwan Setyawan isetyawan at gmail.com
Mon Jan 19 15:54:58 CET 2009


I did try to install the package by itself, with the same result. (BTW, the
error I mentioned earlier should have been dpkg: error processing comerr-dev
(--configure) ).

I also think that this is a packaging error, and not TeXworks related. I'm
not well-versed in debian packaging system, but I suspect that the postinst
script in the package contains errors. I have an idea that I want to try
out, but currently I'm not in front of the Xubuntu box. I'll try it tomorrow
and -- if it works -- I'll post it here. In the meantime, any ideas or
outright solutions are very welcome. :)

I've searched the Ubuntu forum and found a few posts describing similar
error. But I don't see any solution to this error yet.

- Iwan

On Mon, Jan 19, 2009 at 7:36 PM, Jonathan Kew <jonathan at jfkew.plus.com>wrote:

> On 19 Jan 2009, at 11:57, Iwan Setyawan wrote:
>  Hi,
>> I'm trying to build TeXworks on Xubuntu 8.10. I followed the directions
>> here: http://code.google.com/p/texworks/wiki/Building. However, I'm
>> encountering some problems when the system tried to setup the comerr-dev
>> package (version 1.41.3-1ubuntu1). The system gives the following error:
>> install-info: No dir file specified; try --help for more information.
>> dpkg: error processing comerr-dev (--install):
>> And since some other packages depends on this package (or depends on a
>> package that depends on this one), they are not installed correctly either.
>> Can anybody give me hints how to proceed? Is it possible to modify the
>> script(s) inside the .deb file to circumvent this problem?
>> Any help is greatly appreciated.
> I haven't heard of this before (never even heard of comerr-dev, though very
> likely it's been automatically installed as a dependency of other things).
> If you try to install comerr-dev itself directly using Xubuntu's package
> manager, do you encounter the same problem? This sounds like a packaging
> error in that package (rather than anything directly related to TeXworks),
> and should be reported to its maintainers.
> Have you tried searching the (X)ubuntu support forums for any information
> on this? If that package is currently broken in their repositories, I'd
> expect there to be problem reports around somewhere....
> JK
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://tug.org/pipermail/texworks/attachments/20090119/af72b708/attachment.html 

More information about the texworks mailing list