tlmgr doesn't work

Lars Madsen daleif at
Thu Dec 2 09:20:31 CET 2021

It is fairly simple, if you use TexLive from a linux dist tlmgr can only be used for certain configuration tasks.

tlmgr from a Linux dist cannot be used for package update, package installation or updating tlmgr itself.

The Linux dists wants you to get updates and install latex packages through their package system, not through tlmgr.

The fact that the linux dist does not update latex packages is unfortunate.

For linux I personally always use the upstream TeXLive from, which has a fully functional tlmgr.

Lars Madsen

Institut for Matematik
Aarhus Universitet at math<>

From: texhax < at> on behalf of Torbjörn Svensson Diaz <torbjorn.svensson.diaz at>
Sent: 30 November 2021 21:48
To: texhax at <texhax at>
Subject: tlmgr doesn't work


I have trouble using tlmgr.

user at user-desktop:~/Documents/Programming/LaTex$ sudo tlmgr update --self
(running on Debian, switching to user mode!)
Cannot determine type of tlpdb from /home/user/texmf!
cannot setup TLPDB in /home/user/texmf at /usr/bin/tlmgr line 6424.

The same result appears when I try to install packages. I run Ubuntu
18.04.6 LTS.

What am I to do? Can someone please help me?


Torbjörn Svensson Diaz

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the texhax mailing list.