Errors when trying to install the latest version

Adam Frank phil.math.logic at
Wed Apr 29 07:18:40 CEST 2020

I tried installing the marvosym package on Linux Mint.  I don't remember
how I originally put TeX Live on this computer, I think it was just by
opening a terminal and typing `sudo apt-get install texlive-full`.

Anyway, when I executed `tlmgr install marvosym` I got an error about my
installation being old.  So I tried to update.  Downloaded the 2020
version, ran the installer.  I think I added the new path to the executable
although I really don't know what I'm doing here.  At the end of my
`~/.profile` file I added the line

`export PATH=$PATH:/usr/local/texlive/2020/bin/x86_64-linux`

as I think it was indicated by instructions I found googling.  I then
restart the computer, open the terminal, and try to test it for the newest
version.  But it all seems to fail.  `latex --version` reports the old
version.  When I try to install it reports a checksum error.  I looked up
that error, all that I found was to suppress the error with a flag, but
that results in the error

`tlmgr: Local TeX Live (2019) is older than remote repository (2020). Cross
release updates are only supported with update-tlmgr-latest(.sh/.exe)

I tried finding fixes for this error but nothing seems right.  The main
solution I found seemed to be setting a repo to an old version, which as
far I can tell is the source of the error in the first place.  So I'm not
sure where to go from here.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the texhax mailing list.