problem with new MikTex and new emacs installations--SOLVED

Christopher W. Ryan cryan at
Tue May 7 14:43:51 CEST 2019

Just to close the loop on the list:

At Vince Goulet's suggestion, I looked for and found a stray
installation of AUCTeX 11.89-4 in my ~/.emacs.d folder that was
"overruling" the AUCTeX version that comes packaged with his modified
version of emacs.  When I renamed that AUCTeX directory, the problem ceased.

--Chris Ryan

Peter Flynn wrote:
> On 02/04/2019 15:40, Christopher W. Ryan wrote:
>> I'm probably in over my head.  Also, I'm not at that computer right now.
>> But trying to remember from yesterday:
>> 1. When I compiled a tex document in the newest Goulet emacs using tex
>> -> pdf, I got the error about "Symbol TeX p" something.  But when I
>> instead used tex -> dvi -> ps -> pdf, everything worked fine.
> You posted a log file which (I think) you said was the output of pdflatex.
>> 2. Does the -Q switch disable all the AUCTeX add-ons?  
> No. -Q is an Emacs switch, not an AUCTeXC switch. It stops Emacs loading
> your .emacs file, and all the other startup files in your .emacs.d
> folder, and maybe some startup files in the distribution folders, I
> don't know exactly. All of them should happen long before it ever gets
> around to loading AUCTeX.
>> If so, then how
>> was I able to run pdflatex with C-c C-c (defaults to pdflatex) ENTER? I
>> thought that key sequence was part of AUCTeX, not emacs itself.
> I don't know why that is operative. C-c C-f RET is how you run normal
> TeX/LaTeX, and that's in tex-mode and latex-mode. I think you probably
> need to ask advice from an AUCTeX person on this.
> Peter

More information about the texhax mailing list