[texhax] [XeTeX] When using more than 16 math alphabets, \mathtt uses italic font

Vafa Khalighi vkhalighi at me.com
Sun Jun 24 08:15:44 CEST 2012

Another example attached. No problem with lualatex, but with xelatex, this time, \mathtt is fine but you get italic with \mathcal.

On Jun 24, 2012, at 12:41 PM, Vafa Khalighi <vkhalighi at me.com> wrote:

I know that in TeX, you can only use 16 math alphabets but XeTeX extends this so I was curious to enlarge the number of my math alphabets and I had to redefine some internals of LaTeX. My minimal working example is attached.

But this makes the word "Test" to apear in Italic. You can delete any of the \DeclareSymbolFont and then \mathtt worked as expected. This shows that this only happens when the number of math alphabets exceeds 16. Why does this happen and how should one fix this?

I tried the same thing with luatex and I got expected result so it seems that something is wrong with XeTeX.

Subscriptions, Archive, and List information, etc.:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/texhax/attachments/20120624/7df47b65/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: test1.tex
Type: application/octet-stream
Size: 1884 bytes
Desc: not available
URL: <http://tug.org/pipermail/texhax/attachments/20120624/7df47b65/attachment-0001.obj>

More information about the texhax mailing list