[texhax] problem with MathTime Pro 2 fonts and MikTeX

Stan texforeverything at att.net
Sun Jan 15 06:51:44 CET 2012

>> I'm trying to install MathTime Pro 2 fonts to use with MikTeX 2.9
>> (using WinEDT 6 under Windows 7).  I used the instructions at
>> http://www.pctex.com/kb/56.html, but this didn't work.  I tried to
>> typeset this with Plain TeX:
>> \input mtp2
>> text.
>> \bye
>> but got an error.  The log file's empty, but I copied/pasted the
>> text that shows up at the bottom of the screen in WinEDT at the
>> bottom of this message.  Has anybody had the same problem, or can
>> anyone make sense of the errors?  I checked, and the tfm files are
>> in my root directory.  I also checked another installation of MikTeX
>> on a Windows XP computer, and everything works fine there even
>> though there's no file named "mt2m.cfg" there, either.
>> Thanks,
>> Stan
> Use search engines, Stan. For example, google gives me these:
> http://sourceforge.net/projects/miktex/forums/forum/33790/topic/4387778
> http://forums.pctex.com/viewtopic.php?t=12&sid=6c02e77729f71d0a027fcb20bad31428

I found those pages too.  Reinstalling as suggested in the first page  
didn't fix the error I'm getting.  (Mine's similar but not identical to  
the one on the sourceforge page.)

> P.S. Did you try MT Pro 2 with LaTeX?

Yes, with no luck.

I might have found the problem, but I still don't know how to solve it.  I  
decided to open "updmap.cfg" in a text editor, and saw that it doesn't  
have the lines from step 5 in http://www.pctex.com/kb/56.html.  I searched  
for other files with the same name, and found one in my "roaming" folder  
under "appdata".  It was created when I did step 4.  It contains only the  
following lines:

%% T1 font configuration settings. See the MiKTeX manual for help.
# MathTimePro II
Map mtpro2.map

It doesn't seem to matter what directory I'm in when I run the initexmf  
line and the updmap line in steps 4 and 7.  It's not modifying the right  
copy of updmap.cfg.  (Or what I think it the right copy, the one under  
C:\Program Files (x86)\MikTeX\....)  I can't modify that file directly in  
a text editor, since I don't have permission to save to its location.   
Making a copy of it in My Documents, modifying it in a text editor, and  
then replacing the original with that copy didn't work.  Do you know if  
that's the copy that needs to be changed?  I couldn't find anything in the  
MikTeX manual about it.



More information about the texhax mailing list