[texhax] How to getnonfreefonts?

Brandon Kuczenski brandon at 301south.net
Wed Apr 14 19:34:33 CEST 2010

Hey everyone,

Sorry to ask a question that seems to come up frequently, but the font 
system does seem to be robust against easy explanation.

I was overjoyed to see the invention of 'getnonfreefonts' as a way to 
automate the installation of some common [though undistributable] fonts. 
I seem to remember being awestruck by its simplicity of use when I used it 
in the past to install arial-urw.

However, this morning, on my up-to-date texlive system, I tried to install 
garamond with: getnonfreefonts garamond;  it went through all the 
motions, downloaded and extracted the files, ran updmap and so on, and 
completed without errors.  But when building a LaTeX document, with 
\renewcommand{\rmdefault}{ugm}, dvips outputs a lot of lines like:

mktexpk: don't know how to create bitmap font for ugmr8r.
dvips: Font ugmr8r not found,  using cmr10 instead.

then dvips terminates with:
dvips: ! invalid char 150 from font ugmr8r

My missfont.log:
mktexpk --mfmode ljfour --bdpi 600 --mag 2+44/600 --dpi 1244 ugmr8r
mktexpk --mfmode ljfour --bdpi 600 --mag 1+0/600 --dpi 600 ugmr8r
mktexpk --mfmode ljfour --bdpi 600 --mag 1+264/600 --dpi 864 ugmr8r
mktexpk --mfmode ljfour --bdpi 600 --mag 1+0/600 --dpi 600 ugmri8r
mktexpk --mfmode ljfour --bdpi 600 --mag 1+120/600 --dpi 720 ugmri8r

I observed that in $HOME/texmf I have a copy of ugmr8r.tfm.  I also have 
ugm* files of type tfm, afm, pfb, map, and vf.

I tried to run getnonfreefonts-sys, using the -f option, but that didn't 
have any effect (it downloaded and installed the font again, but the 
problem persists).  Moreover, the fonts were not installed system-wide- 
they remain only in my $HOME/texmf tree.  This is all utterly mysterious 
to me.

what am I missing?


More information about the texhax mailing list