[texhax] Problem with dvips and truetype fonts

Edsko de Vries edsko at edsko.net
Thu Jun 5 15:49:29 CEST 2008

Hi guys,

I'm hoping somebody can help me with the following problem. I am using a
Chinese truetype font (Simkai) in my document. I used the instructions
at http://www.math.nus.edu.sg/aslaksen/cs/cjk.html to install it
(replacing Bitstream by Simkai). This worked perfectly until recently.
Now (not having changed any settings, but probably having upgraded Latex
at some point; I'm running Debian Lenny/testing), I get the following
error message when I run dvips:

# dvips -E -o mozi.eps mozi.dvi -R0
This is dvips(k) 5.96.1 Copyright 2007 Radical Eye Software (www.radicaleye.com)
' TeX output 2008.06.05:1416' -> mozi.eps
dvips: ! Couldn't find header file simkai.ttf.
Note that an absolute path or a relative path with .. are denied in -R2 mode.

(The only reason I'm passing -R0 is that strange error message; I didn't
use to do that). 

Now I have no idea what this means, and why it was working before but
not anymore. When I put simkai.ttf in the current directory, it finds
it, but generates as 12MB EPS file (instead of the 77 kB file that it
used to generate) which subsequently fails to open. Obviously, it's
using simkai.ttf for something it's not supposed to, but I don't know
what's causing this.

Any suggestions would be very welcome,



More information about the texhax mailing list