[texhax] Any PPCHTeX users out there? [solved]

romeomedina at libero.it romeomedina at libero.it
Sat Apr 16 19:20:59 CEST 2005

Rodolfo wrote:

> I freshly installed tetex-src-3.0.tar.gz in my Mandrakelinux 10.1 Community box, 
> in order to run PPCHTeX to type chemical structure formulas.
> Now, if I run TeX (onto a file containing PPCHTeX pictures)
> from within the directory /usr/local/teTeX/bin/i686-pc-linux-gnu,
> where the executable file `tex' is present, everything goes fine;
> instead, if I run TeX from my home directory, I get the message:
> ! TeX capacity exceeded, sorry [text input levels=15].
> Can anyone explain these two different behaviours 
> and suggest how to work the problem out?
> The file is a very simple trial one, I called it ppchtex.tex.

Karl Berry wrote:

> I think the problem is simple: don't name your file ppchtex.tex.  There
> is already a file by that name in the system, and ppchtex.noc (I think)
> is finding yours instead of the system one.  It works when you invoke
> tex from the bin dir because then it doesn't find your ppchtex.tex.  (I
> think you could invoke tex from anywhere besides your home and it would
> work.)

I renamed the file and now it seems o.k.
I'm reporting all the steps I did in case they be
of help to others interested in PPCHTeX.


System: Mandrakelinux 10.1 Community
When I installed Mandrake 10.1 Community, I chose the following
package installation:

- Office Workstation;
- Multimedia station;
- Internet Station;
- Configuration;
- KDE Workstation,

1) In www.google.com I typed `tetex', then went on the tetex official website: 
   http://www.tug.org/teTeX/, and from there downloaded the files: 
   tetex-src-3.0.tar.gz and tetex-texmf-3.0.tar.gz and copied them in my ~/tmp dir.

2) # urpmi flex
   , and Mandrake installed the package flex-2.5.4a-22mdk.i586.rpm;
   # urpmi bison
   , and Mandrake installed the packages
   bison-1.875d-1mdk.i586 and m4-1.4.1-1mdk.i586;
   # urpmi ed
   , and Mandrake installed the package ed-0.2-31mdk.i586.rpm;
   # urpmi gcc
   , and Mandrake installed the packages
   gcc-3.4.1-3mdk.i586 and glibc-devel-2.3.3-20mdk.i586;
   # urpmi gcc-c++
   , and Mandrake installed the package ed-0.2-31mdk.i586.rpm;
   gcc-c++-3.4.1-3mdk.i586 and libstdc++6-devel-3.4.1-3mdk.i586;
   # urpmi libncurses5-devel
   , and Mandrake installed the packages
   libgpm1-devel-1.20.1-11mdk.i586 and

3) From my ~/tmp dir I did: 
   # mkdir -p /usr/local/teTeX/share/texmf /usr/local/teTeX/share/texmf-dist
   # gzip -dc tetex-texmf-3.0.tar.gz \ | (umask 0; cd
/usr/local/teTeX/share/texmf-dist; tar xvf -)
   , then removed the file tetex-texmf-3.0.tar.gz from my ~/tmp dir.

4) From my ~/tmp dir,
   $ tar xzvf tetex-src-3.0.tar.gz
   $ cd tetex-src-3.0
   $ ./configure
   $ make
   # make install
   , then removed from ~/tmp the file tetex-src-3.0.tar.gz
   and the whole directory tetex-src-3.0.

5) $ mkdir /home/rodolfo/bin
   $ echo $PATH
   , and I got the following output:
   , so I did:
   $ export
   , and then
   $ cd /home/rodolfo/bin
   $ ln -s /usr/local/teTeX/bin/i686-pc-linux-gnu/tex tex

6) In my home dir I created the file `myfile.tex' 
   (ATTENTION: don't call it ppchtex.tex!), and typed in it the following:

   \input m-pictex.tex 
   \input m-ch-en.tex

   , then did: `$ tex myfile'.

6X velocizzare la tua navigazione a 56k? 6X Web Accelerator di Libero!
Scaricalo su INTERNET GRATIS 6X http://www.libero.it

More information about the texhax mailing list