[texhax] More problems with pdflatex

Hartmut Henkel hartmut_henkel at gmx.de
Sat Jan 17 23:18:10 CET 2004

On Sat, 17 Jan 2004, Michael Barr wrote:

> This is a real mystery.  Having finally worked out how to generate a
> good looking version of a file called abcat.tex (which contained a dozen
> or so pages of text, followed by 180 pdf pages), I was now attempting to
> make a 2up version, something that I had done numerous times with the
> version that looked poor on the screen.  The entire file was this:
>  \documentclass{article}
>  \usepackage[final]{pdfpages}
> \usepackage[letterpaper,landscape,margin=.5in]{geometry}
>  \begin{document}
>  \includepdf[pages=-,openright,nup=2,delta=.5in 0]{abcat.pdf}
>  \end{document}
> You will see that it sets no text at all.  To my great surprise, it now
> won't compile because it says it cannot find the fonts.  Now the file
> abcat.tex actually uses fonts, but this one doesn't.  The first error
> message was
> ! Font \csname\endcsname=aicmsl10 not loadable: Metric (TFM) file not
> found.
> \@EveryShipout at Output ... at Org@Shipout \box \@cclv
> l.5 ...=-,openright,nup=2,delta=.5in 0]{abcat.pdf}
> When I ran it in non-stop mode, there were many more messages like that.
> The resultant pdf file would not load in the Adobe reader.  What is
> going on here.  And why did the file that used fonts run fine, while
> this one that doesn't gets hung up here?

It _could_ be as follows: You have typeset the original, say with a TFM
font aiwhatever10, and with a pdftex.map (extract) about this:

aiwhatever10 <aiwhatever.pfb
aicmsl10 AICMSL <aicmsl10.pfb

Then the aiwhatever.pfb is embedded in your original PDF file abcat.pdf.
Now you include file abcat.pdf by pdfpages. The following happens:
Pdftex always checks the BaseName entry of any font from a loaded file
(abcat.pdf) against the psname entry (2nd field) in pdftex.map - this
field DOES matter in this case: Your aiwhatever.pfb font file happens to
have a BaseName of e. g. AICMSL, or some name, which you find on the
mapfile line starting with the faulty tfm entry aicmsl10 (which you
didn't use for typesetting the original; otherwise it would have crashed
already earlier). Then pdftex tries to replace the font aiwhatever.pfb
coming with the file abcat.pdf by a fresh version, in this case
aicmsl10, where the TFM file is not available by some reason.

If it is like this, you might get rid of this problem, if you look up
the pdftex.map line starting with aicmsl10, and testwise change the 2nd
field to something else, or you remove it. (If the described scenario is
the crash reason, a new pdftex patch would prevent this situation in a
future pdftex release).

Regards, Hartmut

More information about the texhax mailing list