Re: [texhax] Trying again: can't find pdflatex.emft 

Alan T Litchfield alan at
Mon Dec 15 22:46:00 CET 2003

On 15/12/2003, at 11:54 PM, Kaja P. Christiansen wrote:

>>> "I can't find the format file `pdflatex.efmt'!"
> This problem has been reported for other platforms too. Here is
> a 'hack' which will hopefully solve it; let me know if it worked for 
> you.
>> From the Terminal window, run the program:
>     fmtutil --all
> fmutil will create (or recreate) all formats which are present
> in the global configuration file.
Hmm, OK. Running fmtutil --all with the selected packages produced an 
interesting result. There was lots of output and the program seemed to 
go into a loop, repeating these lines, with lots of output between each 
repetition of this. I am sorry, I did not keep the output because it 
threatened to fill the hard disk, and I had to kill the process to stop 

> Catalan Hyphenation Patterns `cahyphen' Version 1.11 <2003/07/15>)
> ! I can't find file `hrhyph.tex'.
> <to be read again>
>                    \relax
> l.328   \repeat
> Please type another input file name:
> ! Emergency stop.
> <to be read again>
>                    \relax
> l.328   \repeat
> No pages of output.
I have solved the problem for me, kind of. I have installed a Full 
Generic Install (all 780-odd Mb of data), I ran texhash and got the 
same result as before (fmtutil.cnf could not be found, it did not exist 
in web2c). So I ran fmtutil --all and that produced a lot of output, 
but not looping like it did before. I ran texhash again and now it 
works :)

The problem appears to be related to etex specifically, and the 
hyphenation for Hungarian, as Maarten suggested.

So, there is a problem there but I am not skilled enough to know where 
to look to fix it.


More information about the texhax mailing list