[tex4ht] Is this a bug in cutAt for tex4ht?

Nasser M. Abbasi nma at 12000.org
Sun Jun 12 00:14:26 CEST 2016

I have large document, book style, and I want to split
it to 3 levels in HTML, but and I want to prevent splitting
at one chapter (becuase I want this specific chapter content
to be all on one web page). So I used the commands


just before the start of the chapter I do _not_ want to be
split and add \ContCutAt{chapter}  just after chapter is done.

But I get an error. I am not sure if I am doing something
wrong or this is a bug. Could some tex4ht expert please
verify?  Here is MWE




\PauseCutAt{chapter} % do not SPLIT this chapter
      \subsection{Text book}

\ContCutAt{chapter} % resume normal operations


Compiled using

make4ht foo.tex "htm,3"

Error is
(./foo.aux) [1] [2]
chapter 1.
l.18 --- TeX4ht warning --- \Link{tailfoch1.htm}? ---
(./foo.4ct) (./foo.4ct
! Missing number, treated as zero.
<to be read again>
l.3 ...sname{2}{x2-20001.1}{QQ2-2-2}{Syllabus}}{3}

Compiling with "htm,1"  or "htm,2" does _not_ give an error.

And just in case I am confused about if I should use
\PauseCutAt{section} instead of \PauseCutAt{chapter}
and \ContCutAt{section}  instead of \ContCutAt{chapter}
I also tried it both way. Still gives an error.

I also tried report class and tried standard book style,
still get an error.

Am I doing something wrong?  TL 2015 on Linux mint. I rememebr
this used to work.

thank you,

More information about the tex4ht mailing list