tlshell --help (pretest, Windows10)

Jerzy Ludwichowski Jerzy.Ludwichowski at
Sat Mar 19 02:05:10 CET 2022

,Hi Siep

W dniu 18.03.2022 o 22:48, Siep Kroonenberg pisze:
> On Thu, Mar 17, 2022 at 03:36:24PM +0100, Siep Kroonenberg wrote:
>> On Wed, Mar 16, 2022 at 08:32:14PM +0100, Jerzy Ludwichowski wrote:
>>> Hi,
>>> tlshell displays a small info window "Backend gone. Last command:" when run
>>> e.g., like
>>>      tlshell -h
>>> or
>>>      tlshell --help
>>> or even the Windows way
>>>      tlshell \?
>>> and goes away when the OK button is clicked in that window.
>>> On the other hand it accepts options like "--gui" and "--gui-lang NN", or
>>> both.
> r62795: now pops up a messagebox which points to the built-in help.

can't confirm yet, 'cos on my way to do so I stumbled upon a problem 
which I seem to have seen reported elsewhere.

Events shown below happen in tl2022 pretest, windows 10, command line in 
the same CLI instance where a clean & happy full installation was made.

To get the new tlshell I asked

     tlmgr update --list

and it replied that indeed, amongst other changes, a new version of 
tlshell is available:

> update:   tlshell.win32     [2707k]: local:    62700, source:    62728

So I did:

> tlmgr update --all

and got a smooth update ride until:

> [35/36, 01:59/02:03] update: tlshell.win32 [2707k] (62700 -> 62728) 
> ... tar: Could not create file tlpkg/tltcl/bin/tcl86.dll: Permission 
> denied
> tar: Could not create file tlpkg/tltcl/bin/tk86.dll: Permission denied
> tar: Could not create file tlpkg/tltcl/bin/wish.exe: Permission denied
> tar: Could not create file tlpkg/tltcl/bin/zlib1.dll: Permission denied
> tar: Could not create file tlpkg/tltcl/lib/reg1.3/tclreg13.dll: 
> Permission denied
> TLUtils::untar: C:\texlive\2022\tlpkg\installer\tar.exe xmf 
> C:\Users\jbl1\AppData\Local\Temp\RnwnCqz4dC\n1w00pELkw/tlshell.win32.tar 
> failed (in C:/texlive/2022)
> TLPDB::_install_data: untar failed for 
> Installation of new version of tlshell.win32 failed, trying 
> to unwind.
> Restoring old package state succeeded.
> done

... the smooth ride continued with formats being recreated until the 
final messages

> package log updated: C:/texlive/2022/texmf-var/web2c/tlmgr.log
> command log updated: 
> C:/texlive/2022/texmf-var/web2c/tlmgr-commands.log
> An error has occurred. See above messages. Exiting.

Permission denied -- what the heck???

To cut the story short: I seem to have found the culprit.  The parental 
install-tl-20220315 folder and each and every its subfolder, including  
tlpkg (please note the name of  folder pointed to by the error msgs) and 
its subfolders into which tar tried to put tlshell in is being reported 
by Windows as allowing *only **read access* to xontained files. No 
individual files do have a read-only attribute set. A simple

     dir /s /ar

command won't tell you anything, you have to employ the windows explorer.

There is no dependence  on the unpacker: I've unpacked 
both with the 7-Zip and native windows unpacker -- same result.


 1. How should be constructed?
 2. How do I get tlmgr to install tlshell after having fixed the
    permissions manually? In reply to update --list all it tells me:

> package repository 
> (not verified: gpg 
> unavailable)
> would save backups to C:/texlive/2022/tlpkg/backups
> no updates available

-- Jerzy Ludwichowski

More information about the tex-live mailing list.