Installing TeXlive 2021 scheme-minimal: I can't find file `dehypht-x-2021-02-26.tex'

Philipp Tempel latex at
Thu Jul 1 13:39:08 CEST 2021

Hello to everyone,

Ulrike Fischer recommended I write an email to the TeXLive group rather than posting my problem on the TeX stackexchange. In essence, this is my question found at but with a few minor updates.

So, I'm trying to build various Docker images for the different TeXLive schemes `infraonly`, `minimal`, `basic`, `small`, `medium`, and `full`. But, as of recently, I cannot build docker images for some TeXLive schema (as of this writing it fails for tl-20210701, but also didn't work with tl-20210622); my weekly builds fail already at installing the minimal scheme. The important section of the log reads:

> `Skipping module "grouptypes"; Loading module "interactionmodes";
> Skipping module "nodetypes"; Skipping module "iftypes";)
> (/usr/local/texlive/texmf-dist/tex/generic/config/language.def
> (/usr/local/texlive/texmf-dist/tex/generic/hyphen/hyphen.tex)
> ! I can't find file `dehypht-x-2021-02-26.tex'.
> \addlanguage =#5 \uselanguage {#1}\input #2 
>                                                   \if *#3*\else \input #3 \f...
> l.32 ...1-02-26}{dehypht-x-2021-02-26.tex}{}{2}{2}
> (Press Enter to retry, or Control-D to exit)
> Please type another input file name: 
> ! Emergency stop.
> \addlanguage =#5 \uselanguage {#1}\input #2 
>                                                   \if *#3*\else \input #3 \f...
> l.32 ...1-02-26}{dehypht-x-2021-02-26.tex}{}{2}{2}
> !  ==> Fatal error occurred, no output PDF file produced!
> Transcript written on pdftex.log.
> fmtutil [INFO]: log file copied to: /usr/local/texlive/texmf-var/web2c/pdftex/pdftex.log
> fmtutil [INFO]: --- remaking etex with pdftex
> fmtutil: running `pdftex -ini   -jobname=etex -progname=etex -translate-file=cp227.tcx *etex.ini' ...`

The lengthy console log, including all the commands I entered after starting the docker image and all the console output I received, are attached in E3s4QAXh.log

My steps to reproduce:
 1. docker run -it ubuntu:focal /bin/bash
 2. apt update && apt install packages like curl, wget, etc.
 3. mkdir /tmp/texlive && cd /tmp/texlive
 4. wget --user=anonymous --password=ftp --no-parent --no-verbose --recursive --no-directories
 5. ./install-tl -profile=/tmp/texlive/texlive.profile -repository=
 6. export PATH="/usr/local/texlive/bin/x86_64-linux/:$PATH" and hash -r
 7. tlmgr install scheme-minimal
The last step is where it fails. It also fails if I want to `tlmgr install scheme-basic` or `tlmgr install scheme-small`, only works when I `tlmgr install scheme-medium`.

This leads me to believe that there is something wrong in how the schemes are set up i.e., some file is missing in scheme-basic that is only available when installing scheme-medium. Surprisingly though, I installed scheme-infraonly locally on my Ubuntu 20.04 a few weeks ago and that worked like it should, though on my build machine, it didn't work at that time either. I did install the different schemes sequentially from `scheme-infraonly` to `scheme-full`

The texlive.profile I use for installing texlive (see step 5. in above list) is attached.

What am I missing here? I first thought I might have a gotten a bad mirror, but tried it on several days, at different hours of the day, and from different machines. Even tried it again (in docker, and a VM Ubuntu 20.04 guest on a Ubuntu 20.04 host, mirror/repository were and just before sending this email. No difference, still fails at installing `scheme-minimal` with the same message of "I can't find file `dehypht-x-2021-02-26.tex'."

The dockerfiles I use are hosted at and you are more than invited to clone, fork, try, etc.

Thanks in advance and have a lovely day, everyone.

Philipp Tempel

E: latex at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: E3s4QAXh.log
Type: text/x-log
Size: 23514 bytes
Desc: not available
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: texlive.profile
Type: application/octet-stream
Size: 929 bytes
Desc: not available
URL: <>

More information about the tex-live mailing list.