Error on printing PDF document with pdflatex.exe

Siep Kroonenberg siepo at
Fri Jun 28 16:56:23 CEST 2019

On Fri, Jun 28, 2019 at 07:40:42AM +0200, dennis neetix | wrote:
> Hi,
> I really hope I can find some help here. I've been researching this topic on
> the net for about 2 weeks now, have already sought help at various other
> places, but always without success (often with the hint that this is the
> wrong place to ask for help). Therefore I sincerely hope that I can get help
> here.
> My story's a little longer. So I'll start at the beginning. If you need more
> information about some points, please let me know, then I will add them.
> I'm using pdflatex.exe to produce PDF files via a webpage.
> That worked fine 2 or 3 years ago with the help of MiKTeX. Now I'm working
> again on this project and I did not work anymore. So I tried to install a
> new version of MiKTeX, but I wasn't able to install it on my Windows 10
> computer (development machine). With MiKTeX portable I was able to produce
> PDF documents in the console, but it still did not work with my software. It
> did not even start to produce the PDF file (no .aux or .log files have been
> created).
> So lately I switched to TeXLive.
> Here I was also able to produce PDF documents in the console of Win10.
> When I use the exact command in my software it starts to produce the PDF
> file (.aux and .log files being created), but it throws an error:
> {d:/Program
> Files/TeXLive/texlive/2019/texmf-var/fonts/map/pdftex/updmap/pdftex
> .map
> !pdfTeX error: pdflatex.exe (file d:/Program
> Files/TeXLive/texlive/2019/texmf-v
> ar/fonts/map/pdftex/updmap/ fflush() failed (Invalid argument)
> ==> Fatal error occurred, no output PDF file produced!

Near the end of the logfile I see mention of MiKTeX:

>          $cwd = 'D:/Files/Company/Einzelunternehmung
> Me/Kunden/Customer/Software/public';
>          $env = null;
> $this->execute = '"' .str_replace('/','\\',env('PDFLATEXENGINE', 'C:/Program
> Files (x86)/MiKTeX 2.9/miktex/bin/pdflatex.exe')) .'"
> "D:\Files\Company\Einzelunternehmung
> Me\Kunden\Customer\Software\app\Classes\Rechnung\LaTex\Output\Rechnung_yTi8J
> xtZyNV2UW8OmYVI_000053-19"
> -output-directory="D:\Files\Company\Einzelunternehmung
> Me\Kunden\Customer\Software\app\Classes\Rechnung\LaTex\Output\" -jobname="'
> .str_replace('.pdf','',$this->pdfFileName) .' ' .$this->latexFilePath .'"';
> $process = proc_open('"' .$this->execute .'"', $descriptorspec, $pipes,
> $cwd, $env);

It looks to me that your script does not know yet that you are now
using TeX Live.

Siep Kroonenberg

More information about the tex-live mailing list