biber, two issues

mario chiari ml at
Sat Jun 15 01:31:38 CEST 2019

On Thu, 2019-06-13 at 10:15 +0200, Zdenek Wagner wrote:
> > 
> It can be a web server problem. I do not know which SW you use.
> Remember that e.g. Apache does not expose your environment to the
> CGI/PHP scripts unless they are set in the *.conf files by PassEnv
> and/or SetEnv directives. For security reasons, /tmp and /var/tmp are
> not used directly, a virtual filesystem is built there and files
> created by one CGI/PHP process do not exist for another CGI/PHP
> process. Thus you PHP script can see the file as /tmp/something but
> the real file will be /tmp/somedir/something where somedir is
> unpredictable. I have my own wrappers if I need to do such things.
Thanks, but I am not sure to know enough to understand. Need to do some more
homework :-)

I tried a MWE, a very simple php script:

$test0 = `/usr/local/texlive/2019/bin/x86_64-linux/biber --help`;
echo "biber: <pre>$test0</pre>";
$test1 = `/usr/local/texlive/2019/bin/x86_64-linux/latex --help`;
echo "latex: <pre>$test1</pre>";

If I run it from terminal, both outputs; if I run it from a web browser, biber
does not seem to be called at all (latex is called)

Is it expected behavior? Otherwise, what could it be wrong?


(I am on Fedora29, texlive2019, FirefoxDev)

More information about the tex-live mailing list