[tex-live] PERL/TK installer

Philip Taylor P.Taylor at Rhul.Ac.Uk
Mon Nov 26 14:58:31 CET 2018

As the new TCL/TK installer doesn't expose TEXMFSYSVAR and 
TEXMFSYSCONFIG locations, I used the original installer when trying to 
install TeX Live from home and ran into the following problems (none of 
which are related to TEXMFSYSVAR/TEXMFSYSCONFIG) —

1) I downloaded the full installation repository using Rsynch to 
2) I tried to install using install-tl-advanced.bat and was told 
(paraphrase, not at home as I am composing this) "Inadequate 
permissions"; changing ECHO OFF to ECHO ON disclosed that this occurred 
at the point "call "%~dp0install-tl-windows.bat" -gui perltk %*"
3) I invoked "install-tl-windows -gui perltk" by hand (which succeeded) 
but then found that it was trying to install from Oxford rather than 
from my local repository.
4) I consulted the documentation and found that it inconsistently 
described the format of the "repository" qualifier, some places stating 
that it was to be preceded by a single minus sign and some by a double.  
I tried both, as in :

  * install-tl-windows.bat" -gui perltk -repository .
  * install-tl-windows.bat" -gui perltk --repository .

and it barfed on both.  Only :

  * install-tl-windows.bat" -gui perltk -repository
    C:\TeX\Live\2018\Repository succeeded.

Could anyone shed any light on these problems, please ?
Philip Taylor

More information about the tex-live mailing list