[tex-live] biber (2.6) and biblatex (3.10) incompatible

Christian Stadelmann christian.stadelmann at mailbox.org
Sat Feb 10 12:05:00 CET 2018

Dear all,

currently, when installing texlive through tlmgr, it will install biber
2.6 and biblatex 3.10, which are incompatible. As a result, any run of
biber will fail, rendering it useless:

INFO - This is Biber 2.6
INFO - Logfile is 'outdir/Thesis.blg'
INFO - Reading 'outdir/Thesis.bcf'
ERROR - Error: Found biblatex control file version 3.4, expected
version 3.2.
This means that your biber (2.6) and biblatex (3.10) versions are
See compat matrix in biblatex or biber PDF documentation.

This issue has been raised before (in November 2017, see [1]). At that
time, there were issues with biber/biblatex, which resulted in an
update being redrawn. These bugs are now fixed, as the MiKTeX builds
work fine.

There was an issue with tex4ht (in the same thread), but I am not sure
it is fixed. There was no update to tex4ht at least. On the other hand,
tex4ht hasn't seen an update for years and the base has moved a bit.
From a web search it seems like there are several fixups needed to make
tex4ht work with modern tex packages anyway, so I doubt this can be
fixed from the texlive side.

Are there any plans to update biber to a version compatible with

[1] https://tug.org/pipermail/tex-live/2017-November/040776.html

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 1528 bytes
Desc: This is a digitally signed message part
URL: <http://tug.org/pipermail/tex-live/attachments/20180210/2d6e3982/attachment.sig>

More information about the tex-live mailing list