[tex-live] how to get info about Lua interpreter version from command line

jfbu jfbu at free.fr
Fri Jun 2 16:31:05 CEST 2017

Le 2 juin 2017 à 16:23, Philip Taylor <P.Taylor at Rhul.Ac.Uk> a écrit :

> Norbert Preining wrote:
>>> Should, of course, have read "What about /pre/-version 0.75 ?".
>> which was in 2013 ... welcome to living in the far past!
> I think you'll find, Norbert, that JFBU is far more concerned about /future/ version changes than historic.  In the absence of any definitive statement from the developers that LuaTeX will be compiled with LUA 5.2 for the remainder of eternity, I continue to believe that JFBU is very wise in wishing to be able to easily check which version.
> ** Phil.

Hi Phil and Norbert,

thanks for the kind help. JFBU indeed thinks luatex is deficient
into not being able to inform straightforwardly the user about
a core component as "lua -v" would do,
but JFBU also thinks that Luatex is never going to become a part
of his future either.

Thanks again,


More information about the tex-live mailing list