[tex-live] texlive setup problems

Charles Campbell astronaut at verizon.net
Thu Feb 2 17:49:39 CET 2017

Norbert Preining wrote:
>> Well, it is peculiar.  I started subshells and the PATH remains the same
>> with /usr/local/texlive/2016/... featured prominently and early.
> sub-shells inherit the settings from the parent shell.
>> However, I did "fix" the problem -- I killed the MATE terminal window,
>> restarted it, and then latex worked properly.
> mate terminal as well as all othe terminals have a parent process
> running, and new terminal windows are spawned from the parent
> process, so the environment of the parent is inherited. Only
> deleting all instances deletes the parent process, and a restart
> gives it the fixes PATH.

Processes inherit PATH from their parent process (and all environment
variables, for that matter), not their grandparent process.  I don't
have a .profile; instead, I have _profile, which I manually source:  .
~/_profile (because I don't have root privilege on my work computer, and
if something goes wrong with .profile it causes problems).

So, if latex was inheriting PATH from the grandparent process somehow,
then I wouldn't have been able to invoke the new latex without a full
path; instead, I would have been invoking the one from SL 7.2.  "which"
would have shown /usr/bin/latex instead of ...texlive.../latex; this
didn't happen.  I could start up new subshells (sh, ksh, bash, etc) and
the PATH in those was correct (ie. inherited from the one in the mate

My _profile does use export PATH, btw.

That's why I said it was weird -- the PATH was correct in the mate
terminal I was attempting to run latex from.  Seems to me something was
left in the environment (not PATH) from earlier attempts that my
_profile didn't change when I re-sourced it that caused latex.fmt to be
looked for in the wrong place, which would explain why terminating and
restarting the mate terminal fixed it (and . ~/_profile, of course).

Chip Campbell

More information about the tex-live mailing list