[tex-live] possible bug or mistake ...

Zdenek Wagner zdenek.wagner at gmail.com
Fri Aug 4 08:11:24 CEST 2017

Hi Paulo,

pdffonts says in our case emb=no which means that the font is not present
in the PDF. The rendering engines is then (almost) free to do whatever it
wants. Usually the engines have their built-in fonts. If a font with the
same name is found, it is usually used but it need not be the intended
font. If it is not found, the rendering engine often has replacement rules
and selects a font. If there is no matching replacement rule, either a
default font is used or nothing is displayed at all. Thius is why documents
without embedded fonts look differently in different viewers. Usually
ghostscript has reasonalbe replacements so you can often fix the problem by
post-processing the PDF file by ps2pdf (yes, it is able to build another
PDF from a PDF).

Zdeněk Wagner

2017-08-04 5:29 GMT+02:00 Paulo Ney de Souza <pauloney at gmail.com>:

> I imagine people are doing this for the sake of XeTeX, and not really to
> use TeX fonts in LibreOffice...so it should be on TL's lap the
> responsibility to get these fonts to XeTeX without damaging anything else
> on the machine - specially a PDF viewer, like Evince.
> It definitely should come out of the manual -- because under the tow of
> that section, tons of people are recommending that all over SX and other
> places. Better yet, the section should probably say
>      ** DO NOT DO THIS ** It was recommended in the past, but we know
> better now that ....
> In the TeX world we are acquainted with a lot of blind-recipes like
> updmap, mktexlsr, texhash, ... some of them people have no idea what is
> going on, so if it is  a recipe out there - it should be a good one!
> I still do not know who is at fault here... Is it the PDF file?
> PST-barcode? fc-cache? The machine? Evince?
> Paulo Ney
> On Thu, Aug 3, 2017 at 6:32 PM, Norbert Preining <preining at logic.at>
> wrote:
>> Ok, a bit more relaxed answer ...
>> > cp $(kpsewhich -var-value TEXMFSYSVAR)/fonts/conf/texliv
>> e-fontconfig.conf
>> > /etc/fonts/conf.d/09-texlive.conf
>> > fc-cache -fsv
>> I know that this is in the manual, but I *STRONGLY* advice against it.
>> There are some broken fonts, some that mess up fontconfig due to naming
>> issues, all kind of bad things can happen. In Debian I have been pushed
>> to do this for long time, but always rejected and recommend people
>> adding only those fonts one by one that they are actually use.
>> Just my 2Yen
>> Norbert
>> --
>> PREINING Norbert                               http://www.preining.info
>> Accelia Inc.     +    JAIST     +    TeX Live     +    Debian Developer
>> GPG: 0x860CDC13   fp: F7D8 A928 26E3 16A1 9FA0 ACF0 6CAC A448 860C DC13
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/tex-live/attachments/20170804/f1f09d23/attachment.html>

More information about the tex-live mailing list