[tex-live] texdoc won't run

Juergen Fenn jfenn at gmx.net
Mon Apr 17 21:06:42 CEST 2017

Hello Dick,

thanks for looking into this.

Am 17.04.17 um 20:04 Uhr schrieb Richard Koch:

> On my machine, running MacTeX-2016 updated a few days ago, texdoc works
> fine,
> pulling up documentation for footmisc and many other things.

BTW, I know it worked on my machine too. But texdoc does not find any
documentation now.

I can live with texdoc.net for the time being, but I reported the
problem in case it should be a bug related to a recent update.

> Here
> /Library/TeX/texbin/texdoc
> is a symbolic link to
> ../../texmf-dist/scripts/texdoc/texdoc.tlu
> Is that true for you?

Yes, it's an alias. And when I drag and drop it from the Finder to
Terminal I get the same result as before:

Mangold:~ juergenfenn$ /usr/local/texlive/2016/bin/x86_64-darwin/texdoc
/usr/local/texlive/2016/bin/x86_64-darwin/texdoc:7: module 'texdoc.main'
not found:
	no field package.preload['texdoc.main']
	[kpse lua searcher] file not found: 'texdoc.main'
	[kpse C searcher] file not found: 'texdoc.main'
	no file '/usr/local/lib/lua/5.2/texdoc.so'
	no file '/usr/local/lib/lua/5.2/loadall.so'
	no file './texdoc.so'
Mangold:~ juergenfenn$


More information about the tex-live mailing list