[tex-live] problem in ltluatex.tex

Ken Moffat zarniwhoop at ntlworld.com
Wed Mar 2 02:30:40 CET 2016

I normally build from source, using the "recipes" in
http://www.linuxfromscratch.org/blfs/view/svn/ (they are mine, I
have to take full responsibility for them ;) but now that we (LFS)
are coming up to a release I tried using the binary version, from
20160226 [ we always used to start from the binary, and I still
recommend it if people want to use the absolute latest versions of
everything ].

I have my own test scripts at
I do not claim they are good, nor that they test everything, but
they seem to work for me on the from-source build.

But in the binary, my lualatex test crapped out:

lualatex lualatex.tex
This is LuaTeX, Version beta-0.80.0 (TeX Live 2015) (rev 5238) 
 restricted \write18 enabled.
LaTeX2e <2015/01/01>
Babel <3.9l> and hyphenation patterns for 79 languages loaded.
Document Class: article 2014/09/29 v1.4h Standard LaTeX document
! Missing number, treated as zero.
<to be read again> 
l.140 \newcatcodetable\catcodetable at initex

? exit
You want to edit file
/opt/texlive/2015/texmf-dist/tex/latex/base/ltluatex.tex at line 140

Line 140 of ltluatex.tex reads:
\newcatcodetable\catcodetable at initex

The command I am running is
lualatex lualatex.tex

And I'll attach lualatex.tex

I tried running tlmgr update --all but that reports no updates

This email was written using 100% recycled letters.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: lualatex.tex
Type: application/x-tex
Size: 1626 bytes
Desc: not available
URL: <http://tug.org/pipermail/tex-live/attachments/20160302/eda1cff8/attachment.tex>

More information about the tex-live mailing list