[tex-live] Unable to use install-tl-windows.exe: "Windows XP earliest supported version; aborting..."

Jon Hood squinky86 at gmail.com
Thu Jun 2 23:27:35 CEST 2016

Can you point me to the code that does the detection and I can try to 
debug it on my end?



On 6/2/2016 10:27 AM, Siep Kroonenberg wrote:
> On Thu, Jun 02, 2016 at 04:13:50PM +0200, Uwe Ziegenhagen wrote:
>> How does the Script determine the windows version it is running on? I would assume windows 7 Enterprise is using a Different identifier than win7 home Or Professional.
> The edition (home/pro/enterprise) is independent from the version
> (xp/vista/w7/w8/w10).  The nsis wrapper script loads the WinVer.nsh
> header file for testing the version, not the edition. This header
> file does have special code for server versions but that is another
> story.
> I just realized that I have remote access to a windows 7 enterprise.
> On that system, too, I could start up the `real' installer.
> I am reluctant to spend a lot of time on this: there have been no
> recent changes in this wrapper, I recall no similar error reports, I
> cannot reproduce the problem, and the affected user found a
> workaround for himself (another workaround is downloading the zip
> version).

More information about the tex-live mailing list