[tex-live] TeXLive 2016 on Ubuntu

Axel E. Retif axel.retif at mac.com
Thu Aug 25 06:31:28 CEST 2016

On 24/08/16 21:13, Br. Samuel Springuel wrote:

> I just installed TL2016 on a Ubuntu 14.04 VM and followed the directions
> on the website (https://www.tug.org/texlive/debian.html) for making
> apt-get aware of the installation.  However, when I then proceeded to
> use apt-get to install TeXworks, the texlive-binaries package got
> installed as well.  Looking at the list, this should be one of the
> packages which the TL2016 installation provides.  Can anyone tell me why
> this might be happening and what (if anything) I can do about it?

I used said method of equivs in https://www.tug.org/texlive/debian.html 
on Ubuntu 15.10 and 16.04 (though not on a VM) and it worked as 
expected. When I installed TeXworks (with Synaptic, but I'm sure it 
would have been the same with apt-get), it only installed

     libqt4-scripttools (4:4.8.7+dfsg-5ubuntu2)
     libsynctex1 (2015.20160222.37495-1)
     texworks (0.5~svn1363-6build2)
     texworks-help-en (0.5~svn1363-6build2)

On the other hand, the binaries you got installed won't affect your work 
if you prepend to your PATH the TeXLive path:


(if your architecture is 64 bit, or the corresponding if it is 32 bit).

*Also*, you have to make sure that TeXworks path

     File -> Preferences -> Typesetting

has the TeXLive path on top (I don't use TeXworks, but Emacs, though I 
just tried it, and it works OK).



More information about the tex-live mailing list