[tex-live] Error when trying to use TeX Live's 2015 tlmgr on FreeBSD 9.3

Conny Andersson tugmember at diaforum.se
Wed Sep 30 02:35:20 CEST 2015


The last six years I have installed TeX Live from the DVD and thereafter
used tlmgr to manage, update and uninstall the TeX Live software without
any problems at all. During these six years my operating system has
always been different versions of FreeBSD.

I got the TeX Collection 2015 DVD on August 28 and uninstalled TeX Live
2014 with tlmgr and reinstalled TeX Live 2015. This was done on
my workstation. After some days i tried to: tlmgr update --all and got
this error message:

Can't locate TeXLive/TLConfig.pm in @INC (you may need to install the 
TeXLive::TLConfig module) (@INC contains: /usr/texmf-dist/scripts/texlive 
/usr/tlpkg /usr/local/lib/perl5/site_perl/mach/5.20 
/usr/local/lib/perl5/site_perl /usr/local/lib/perl5/5.20/mach 
/usr/local/lib/perl5/5.20 /usr/local/lib/perl5/site_perl/5.20 
/usr/local/lib/perl5/site_perl/5.20/mach .) 
at /usr/local/bin/tlmgr line 92.
BEGIN failed--compilation aborted at /usr/local/bin/tlmgr line 92.

My path to TLConfig.pm is: /usr/local/texlive/2015/tlpkg/TeXLive

root at maya [2015/tlpkg/TeXLive] # ls -l 
-rw-r--r--  1 root  wheel   20252  8 Feb  2014 TLConfFile.pm
-rw-r--r--  1 root  wheel    9032 23 Jun 06:33 TLConfig.pm
-rw-r--r--  1 root  wheel    4642  8 Feb  2014 TLDownload.pm
-rw-r--r--  1 root  wheel   75152 13 Jan  2015 TLPDB.pm
-rw-r--r--  1 root  wheel   53048 14 Jun 15:37 TLPOBJ.pm
-rw-r--r--  1 root  wheel   35419 15 Maj  2014 TLPSRC.pm
-rw-r--r--  1 root  wheel   21600 23 Jun 06:33 TLPaper.pm
-rw-r--r--  1 root  wheel   10114 15 Maj  2014 TLTREE.pm
-rw-r--r--  1 root  wheel  119908  6 Maj 22:30 TLUtils.pm
-rw-r--r--  1 root  wheel   36266 21 Dec  2014 TLWinGoo.pm
-rw-r--r--  1 root  wheel    8800 14 Jun 15:37 TeXCatalogue.pm
-rw-r--r--  1 root  wheel    5690 16 Aug  2012 trans.pl

My path to the tlmgr.pl is: 

The same error occurred also on this laptop on which I have installed
TeX Live 2015 via install-tl-unx.tar.gz from the Internet. Both of my
computers runs FreeBSD 9.3 and both get the same error message when
trying to use the tlmgr. (All options I give tlmgr gives the same 
error about line 92.) All the other TeX software works fine, via
softlinks in /usr/local/bin to the actual binaries like xelatex, [XeTeX
3.14159265-2.6-0.99992 (TeX Live 2015)].

Thank you in advance for helping me,
Best Regards,


  Conny Andersson
<tugmember at diaforum.se>


More information about the tex-live mailing list