[tex-live] regression (?) with minimal ctex example

Scott Kostyshak skostysh at lyx.org
Sun May 17 00:43:42 CEST 2015

On Sat, May 16, 2015 at 7:55 AM, Leo Liu <leoliu.pku at gmail.com> wrote:
> Hello Scott,
> I'm afraid that your original MWE is wrong.
> The 'nofonts' option means that we do not use the default Chinese font
> setting and will manually specify the fonts later.
> It is a coincidence that the MWE works in old version of ctex package,
> because recent versions of xeCJK package loads Fandol fonts when no fonts
> are specified. We disabled this feature in ctex version 2.0.
> You can remove the 'nofonts' option and then this simpler MWE should work
> (on Windows, Mac OS X, and Linux):
> \documentclass[UTF8]{ctexart}
> \begin{document}
> 下面开始正文。
> \end{document}
> Anyway, I think the error message should be improved.
> BTW, it doesn't matter to use \usepackage[T1]{fontenc}, if you know what you
> are doing.
> Best,
> Leo

Dear all,

Thank you everyone for your advice and corrections. As for if I know
what I'm doing, I certainly do not (perhaps I should have made that
more clear in my first email). I run tests of all of LyX's
documentation (we now have more than 4000 such tests). If a document
suddenly stops compiling, I investigate why. This list has been very
friendly and helpful in either fixing regressions or pointing out that
the documents are flawed to begin with. I really appreciate that.

Removing the "nofonts" class option leads to a successful compilation
of the MWE as well as the main document from which I derived the MWE.
I will also remove the use of the fontenc package for this document.

Thank you Norbert, Ulrike, Herbert, and Leo!


More information about the tex-live mailing list