[tex-live] Issue installing Tex Live on Windows 10

Siep Kroonenberg siepo at cybercomm.nl
Tue Aug 4 22:53:26 CEST 2015

On Tue, Aug 04, 2015 at 08:56:29AM +0200, Andrea Eugenio Gini wrote:
> Hi, I tried to install Tex Live on a clean installation of Windows 10 home
> 64bit (so the system is clean and recently wiped and reinstalled) but i
> have some issues.
> When I start the installation process via network the CMD (anche
> installation itself) shut down at the very beginning.
> Right after the running of the installer or the batch file a popup show up
> with an alert message. "Error of the application. It is impossible to start
> the application 0xc0000142"
> The title of the pop up is "Perl.exe"

This is the answer I posted on tex.stackexchange:

I just tested with a brand-new wx pro 64-bits and an advanced user
installand had no problems. To be exact: I downloaded the exe,
selected the unpack option and after it finished unpacking I
double-clicked install-tl-advanced.bat, but clicking the advanced
button also started up the main installer interface.

I searched for this "0xc0000142" error. Unfortunately it seems a
pretty intractable beast.

As a workaround, you can do a portable install on a usb stick from
another computer.
> This problem happens everytime at the start of the installation with the
> windows bat file and with the advanced bat file.
> The exe installer simply unpack the file (the green writings in the
> software windows) but after that i can only click the close button and
> nothing happen.
> I imagine that after that normally should autoexecute the installation
> process.
> With the Tex LIve image (iso) the problem is the same that with the archive
> with the batch file.
> The issue happens with administration privilege too.
> The issue happens with execution of batch file directly via prompt and with
> code string of -no-gui or -gui text too.
> I try install an external version of perl (strawberry) but the same happens.
> If I overwrite the perl folder into the zip archive with the bin and lib
> file from the strawberry installation then effectively the installation
> start. Then the CMD stamp a very large list of problem about perl
> (obviously is only a try).
> I think the same issue is present if i copy the lib and bin folder from the
> live cd, because perl.exe crash too in the live cd, so is pointless the
> trying.
> The system is "new", I wiped and reinstalled for two times two days ago.
> Everything went fine, all the programs just work fine and the only issue is
> with Tex Live.
> I need this partucular suite for University.
> I attach a link from the discussion on StackExchange Tex's Board:
> http://tex.stackexchange.com/questions/258364/issue-installing-tex-live-on-windows-10
> Kind regards,
> Andrea Eugenio
> P.S. Sorry for the very bad english

Siep Kroonenberg

More information about the tex-live mailing list