[tex-live] Two problems solved (but it may be useful to report them anyway)

Daniel H. Luecking luecking at uark.edu
Mon Apr 20 23:54:45 CEST 2015

TeX Live pretesters:

I just recently installed the texlive2015 pretest. I ran into only
two problems and those have been resolved, but I thought there might
be others who find themselves in my peculiar position who could 
benefit from hearing this story.

The first problem can arise if you are a windows user, with 
Take Command version 17 installed and you run install-tl-wibdows.bat 
from a TCC command shell. I did this and immediately received the 
Cancel batch job C:\tl\install-tl-20150414\install-tl-windows.bat ? (Y/N/A) :

I traced this to the fragment "%path:~0,1" on line 24, and determined 
this to be a bug in version 17 of Take Command because I updated it 
to the slightly more recent version (17.00.77) and the problem went away.

So if you are a user of TCC, with an early build of version 17 
installed, then either update Take Command or run the install-tl 
batch file in a cmd.exe shell. (You can also run an earlier TCC: 
version 16 works OK.)

The second problem was that my texmf-local/web2c/ contained 
fmtutil-local.cnf and I got the message that I should probably 
rename it to fmtutil.cnf. I did that, but my 15 supposedly 
disabled formats were generated anyway. In the output of 
fmtutil --help one finds one has to use 
"  #! <fmtname> <enginename> <hyphen> <args>" 
to disable a format. 

It turns out that one has to ignore the first two spaces in that 
line, but the space after #! is not optional. I didn't test whether 
the other spaces and arguments had to literally match what 
was in the Tex Live-supplied fmtutil.cnf, but simply  
copy/pasted them, prefixing "#! ", and all was well.

Daniel H. Luecking 
Department of Mathematical Sciences
1 University of Arkansas
Fayetteville, AR, USA 72701

More information about the tex-live mailing list