[tex-live] Problems with Nafees fonts

Ulrike Fischer news3 at nililand.de
Tue Aug 30 15:42:22 CEST 2011

Am Tue, 30 Aug 2011 14:35:24 +0200 schrieb Zdenek Wagner:

> Hello,
> I have problems with Nafees fonts in xelatex. The same problem occurs
> in two Linux distros (CentOS 4 and CentOS 5) with TL 2010 as well as
> TL 2011. I am not sure whether it is a TL specific or OS specific
> problem (or my fault). I did the following:
> 1. unpacked the Nafees fonts to /usr/share/fonts/Nafees, ran fc-cache
> as root, verified that the fonts work in gedit, OpenOffice.org and
> <oXygen/>
> 2. used in xelatex, the error message is:
> ** ERROR ** Cannot proceed without the "native" font: NafeesNastaleeq
> (Nafees Regular)...
> 3. copied the font to the working directory, renamed to urdu.ttf and
> changed the font loading command to use urdu.ttf, now it works and the
> PDF is correct
> 4. I thouhgt it may be a problem of a space in the font name, thus I
> have renamed the font, reran fc-cache, validated that it still works
> in gedit, but xelatex reports the same error
> 5. renamed urdu.ttf to "font urdu.ttf" (space in the file name),
> modified the font loading command to use this file and it works fine
> Am I doing something wrong or is it a bug?

Well without a link to the font it is difficult to make tests. But
if you can load the font if you use the file name but get problems
if you use the font name I would at first check if there is a second
font around with the same font name. 

Put \XeTeXtracingfonts= 1 in your document and compile with 

xelatex --no-pdf file 

this will give you some informations in the log about the used

Then convert the xdv with 

xdvipdfmx -vv file 

to see which fonts xdvipdfmx is using.

Ulrike Fischer 

More information about the tex-live mailing list