[tex-live] "I can't find the format file" problems

Jacob Head tex-live at jacob-head.com
Wed Feb 24 13:49:18 CET 2010

Dear Karl

> Thanks for the detailed report.  Unfortunately, I'm sorry, but you need
> to find whoever is responsible for this netbsd port.  This area of .fmt
> file creation is precisely one of those which varies most widely among
> different versions of TeX (Live), and I can't guess as to wehere the
> problem really lies.

Many thanks. The pkgsrc website seems to be down at the moment but once 
it is back up I will see if I can track down the package maintainer 
(assuming that's what they are called in the NetBSD world) and go from 

> I can only offer the generic advice to check your
> environment variables, and unset anything TeX related.  It's easy for
> old settings to cause failures.

Yes, of course. I tried that before posting and it seemed not to make a 

> If you just want to make a .fmt so you can actually use (la)tex, as
> opposed to debugging these failures, running
> tex -ini tex.ini
> should create a tex.fmt, which you could then move to wherever it will
> be found (I wouldn't want to guess, for your system).

That's very helpful. Running that and installing the resulting file at 
~/.texlive2009/texmf-var/web2c/tex/ allows TeX to function again. 
Running luatex -ini luatex.ini (which I assume would be the equivilant 
command for producing the luatex.fmt file) breaks with the same error 
that fmtutil did:

! Conflicting pattern ignored.
l.4453 }

though forcing it to continue does produce a fmt file which, when 
installed appears to allows luatex to function (albeit with further 
warnings on conflicting patterns whenever it is invoked).

XeTeX simply breaks horriby:

! I can't find file `unicode-letters'.
l.12 \input unicode-letters

> In general, fmtutil.cnf gives the commands to create any given .fmt.
>      (./test.tex [1]xdvipdfmx: not found
> xdvipdfmx is an integral part of XeTeX, not an independent part of the
> flow (as dvipdfmx is).  So if it's not in PATH, xetex has no chance of
> working.

Thanks for that. I wonder if this, and the error above, suggests a 
broken installation of XeTeX.

> Hope this helps somehow,

It does indeed, so thank you. I think I now have a clearer idea of the 
people and questions I should be asking.

Best wishes,


More information about the tex-live mailing list