[tex-live] TeX Live 2008, i386-freebsd, FreeBSD 6.4 and i386-linux

Conny Andersson unitex at telia.com
Sun Mar 15 23:46:54 CET 2009


On March 11, 2009 I wrote that 'Now TeX Live 2008 installs on FreeBSD 6.4' and 
it did. But, I did not run any program then.

The next time I was using my computer was on March 14, and when running
tex --version I got an error that libm.so.5 was missing. I tried to solve the 
problem as Yue Wang wrote on March 11 as an answer to my first problem on
March 9 'TeX Live 2008 does not install on FreeBSD' (6.4):

> for now, I suggest you to try to remap the lib versions (in
> /etc/libmap.conf) to see whether it works.

> Yue Wang

So I did that, but then libc.so.7 did pop up as missing - again - when trying 
to run any TeX-program. And, solving that via /etc/libmap gave ld-linux.so.1 as 
missing. And, solving that gave me 'segmentation fault'. Like Russian dolls ...

Yue Wang had it right, when he on March 11, in a second email wrote that:

> If LZMA and TL binary are built on the same machine, after
> the installation, the problem will appear again.

So, next, I tried out what Manfred Lotz wrote on March 10, in respond to my 
primary problem:

> The FreeBSD binaries were built under FreeBSD 7.0. Try out
> if the Linux i396 binaries are usable.

And, I did rm -Rf /usr/local/texlive, and deleted all symlinks in 
/usr/local/bin to tex-binaries. And, began a brand new texlive-install to run 
the i386-linux texlive on my FreeBSD 6.4.

And, then the install-tl-procedure gave me some problems:

Available sets of binaries:

    a [ ] alpha-linux      DEC Alpha with GNU/Linux
    b [ ] amd64-freebsd    x86_64 with FreeBSD
    c [ ] hppa-hpux        HP-UX
    d [ ] i386-freebsd     Intel x86 with FreeBSD
    e [X] i386-linux       Intel x86 with GNU/Linux
    f [ ] i386-openbsd     Intel x86 with OpenBSD
    g [ ] i386-solaris     Intel x86 with Sun Solaris
    h [ ] mips-irix        SGI IRIX
    i [ ] powerpc-aix      PowerPC with AIX
    j [ ] powerpc-linux    PowerPC with GNU/Linux
    k [ ] sparc-linux      Sparc with GNU/Linux
    l [ ] sparc-solaris    Sparc with Solaris
    m [ ] universal-darwin universal binaries for MacOSX/Darwin
    o [ ] win32            Windows
    p [ ] x86_64-linux     x86_64 with GNU/Linux

But, on pressing <R> return to main menu I get:

Detected platform: Intel x86 with FreeBSD

  <B> binary systems: 2 out of 15

And, when I choose:

<L> create symlinks in standard directories:  [X]
             binaries to: /usr/local/bin
             manpages to: /usr/local/man
                 info to: /usr/local/info

The symlinks in /usr/local/bin/ refer to the:

/usr/local/texlive/2008/bin/i386-freebsd/ directory.

In /usr/local/texlive/2008/bin/ there are two directories:

i386-freebsd and i386-linux.

So, I had to manually:

ln -sf /usr/local/texlive/2008/bin/i386-linux/tex \
/usr/local/bin/tex etc.

Now I can run normal tex-programs like:

unitex at alice [~] > pdflatex --version
pdfTeX 3.1415926-1.40.9-2.2 (Web2C 7.5.7)
kpathsea version 3.5.7
Copyright 2008 Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX). Kpathsea is 
copyright 2008 Karl Berry and Olaf Weber. There is NO warranty. Redistribution 
of this software is covered by the terms of both the pdfTeX copyright and the 
Lesser GNU General Public License. For more information about these matters, 
see the file named COPYING and the pdfTeX source. Primary author of pdfTeX: 
Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX). Kpathsea written by Karl 
Berry, Olaf Weber, and others.

Compiled with libpng 1.2.29; using libpng 1.2.29
Compiled with zlib 1.2.3; using zlib 1.2.3
Compiled with xpdf version 3.02pl2

And, ldd gives, no missing libraries:

unitex at alice [/usr/local/bin] > ldd pdflatex
  libm.so.6 => /lib/obsolete/linuxthreads/libm.so.6 (0x28194000)
  libc.so.6 => /lib/obsolete/linuxthreads/libc.so.6 (0x281bb000)
  /lib/ld-linux.so.2 (0x2816d000)

But, xdvi does not work as one example:

xdvi-xaw: error while loading shared libraries:
libXaw.so.7: cannot open shared object file: No such file or

So, as a conclusion it is not easy to run TeX Live 2008 on FreeBSD 6.4 which is 
newer then the FreeBSD 7.0 on which TeX Live 2008 i386-freebsd was built.

Thank you for engaging in my problem, and best wishes,


   Conny Andersson
<unitex at telia.com>

More information about the tex-live mailing list