[tex-live] XeTeX and ConTeXt

John Hughes jkhughes2 at googlemail.com
Tue Mar 10 22:15:14 CET 2009

2009/3/10 George N. White III <gnwiii at gmail.com>:
> On Tue, Mar 10, 2009 at 3:19 PM, John Hughes <jkhughes2 at googlemail.com> wrote:
>> I have just installed TeX Live 2008 on Windows and am having some
>> problems with XeTeX and ConTeXt. The first problem is that XeTeX
>> cannot access system fonts (using fontspec with xelatex). I have tried
>> running fc-cache -v -r, which generates the following output:
> Did you install from DVD, download, etc?
>> /usr/share/fonts: caching, new cache contents: 0 fonts, 5 dirs
>> /usr/share/fonts/100dpi: caching, new cache contents: 0 fonts, 0 dirs
>> /usr/share/fonts/75dpi: caching, new cache contents: 0 fonts, 0 dirs
>> /usr/share/fonts/cyrillic: caching, new cache contents: 0 fonts, 0 dirs
>> /usr/share/fonts/encodings: caching, new cache contents: 0 fonts, 1 dirs
>> /usr/share/fonts/encodings/large: caching, new cache contents: 0 fonts, 0 dirs
>> /usr/share/fonts/misc: caching, new cache contents: 48 fonts, 0 dirs
>> /usr/X11R6/lib/X11/fonts: skipping, no such directory
>> /home/username/.fonts: skipping, no such directory
>> /var/cache/fontconfig: cleaning cache directory
>> /home/username/.fontconfig: not cleaning non-existent cache directory
>> fc-cache: succeeded
>> It seems to be looking for Linux directories rather than Windows ones.
>> How can I tell it to look in the usual Windows directories?
> I vaguely recall encountering a problem with the configuration for fontconfig.
> I think there are different files for linux and windows.  I wonder if the linux
> paths are a default used when it doesn't find the windows-specific
> configuration.   You should check carefully for remants of some old
> TeX distro.  A number of other packages (gimp?) also use fontconfig,
> so it is possible you are getting a binary or config file other than the
> one from TL.
>> My second problem is that ConTeXt's texexec doesn't do anything. The
>> program is installed, but when I try to run texexec there is a short
>> pause and then nothing happens. There are no error messages at all, it
>> just doesn't seem to do anything.
>> Any help on either issue would be greatly appreciated.
> Do you have ruby?   There has been a lot of progress on ConteXt Mkiv
> since TL2008 was created.   I find the TL version works fine for some
> legacy documents, but if you want to use the new stuff you should get
> the ConTeXt minimals.
> --
> George N. White III <aa056 at chebucto.ns.ca>
> Head of St. Margarets Bay, Nova Scotia

Thanks George,

I installed Ruby and can now use ConTeXt in TeX Live 2008. I am not
quite sure what the advantages of the "new stuff" in Mark IV are for
my relatively simple documents at the moment.

I also discovered that I was accidently using fc-config from Cygwin
rather than the one supplied with TeX Live. However, having removed
Cygwin from the system path and making sure that I using the right
fc-cache, I am still having problems. When I run fc-cache, it seems to
find the fonts in c:/windows/fonts. The problem is that when I run
xelatex or texexec --xtx, I get an error:

Metric (TFM) or installed font not found

Any idea what the problem might be?


More information about the tex-live mailing list