[tex-live] tlmgr problems (linux64)

Axel E. Retif axel.retif at mac.com
Mon Nov 17 07:29:52 CET 2008

On  15 Nov, 2008, at 05:58, Victor Ivrii wrote:

> Dear Karl, Norman
> Yesterday tlmgr update from ftp://tug.org/texlive/tlcritical gone
> rogue and began to remove packages en mass. I interrupted it and
> reinstalled all the collections
> successfully
> However today it began to complain that
> Can't locate object method "option" via package "TeXLive::TLPDB" at
> /usr/local/texlive/2008/bin/x86_64-linux/tlmgr line 1088.

The same happened to me on Thursday-Friday on Mac OS X, but I thought  
I had done something really wrong because...

1) First, I upgraded my Ubuntu distribution, the usual way, and  
everything went well.

2) Then I tried to update my Mac OS laptop, also the usual way, and  
after upgrading bin-texlive, I think, it went nuts, saying

> Installation of new version of <such and such package> did fail,  
> trying to unwind!

I tried again and it said that many packages had been ``forcibly  
removed'', so I tried to reinstall the collections of such packages to  
no avail. So i tried with ftp://tug.org/texlive/tlcritical, and it  
removed almost everything!

Long story short, I reinstalled MacTeX, then did a

sudo tlmgr update bin-texlive texlive.infra

and then upgraded again the usual way, and everything was OK!

3) Afraid of what might happen, before upgrading my Mac OS desktop, I  
tared my 2008 directory, then upgraded first bin-texlive texlive.infra  
and only then upgraded the rest and everything went smoothly.



More information about the tex-live mailing list