[tex-live] minor issues with installer

Mojca Miklavec mojca.miklavec.lists at gmail.com
Thu Jul 31 16:22:40 CEST 2008


(Manual has already answered some of my questions while I sent the
mail to the wrong mailing list, but I'm resending the original.)

I'm working on Mac Tiger with X11 installed.

Because of an old TL08 installation and since some things must have
been broken, I decided to remove it completely and start from scratch.

I first tried to use ./tl-portable (from SVN repository) and run
    texexec somefile

but it stopped at

TeXExec | processing document 'somefile'
TeXExec | no ctx file found
TeXExec | tex processing method: context
TeXExec | TeX run 1
TeXExec | writing option file palat.top
TeXExec | using randomseed 828
TeXExec | tex engine: pdftex
TeXExec | tex format: cont-en
This is pdfTeXk, Version 3.1415926-1.40.9 (Web2C 7.5.7)
 %&-line parsing enabled.

kpathsea: Running mktexfmt cont-en.fmt
I can't find the format file `cont-en.fmt'!
TeXExec | runtime: 11.141305

The strange thing is that I had an empty .texlive2008; it must have
been used once, but maybe it was used for the installation itself.

OK, so I thought I would reinstall TL from SVN.

Platform: universal-darwin => 'universal binaries for MacOSX/Darwin'
Distribution: live (uncompressed)
Directory for temporary files: '/tmp'
Installer directory: '.'
Loading /Users/mojca/texlive/Master/tlpkg/texlive.tlpdb
Can't call method "depends" on an undefined value at ./install-tl line
620, <TMP> line 103757.

I probably have something broken in the SVN repository. I tried to
update several times (the main problem is that I cannot afford to
update "bin", so if some new file appears in Master or if I forget to
update something in the top dir I probably screw up, so I was playing
with svn up and rsync, but might have broken up something, and it's
just too giant to simply delete it and fetch it all again).

So, let's try the network installer then.

If I follow the link small "bootstrap installer available on CTAN" from

then I see the source html instead of webpage. I copy-paste the link
to tar.gz, get it, unzip it, and out of curiosity test the gui (I want
to make sure that our translation is still ok).

> ./install-tl -gui
Platform: universal-darwin => 'universal binaries for MacOSX/Darwin'
Distribution: net  (downloading)
Using URL: http://gd.tuwien.ac.at/publishing/tex/CTAN/systems/texlive/tlnet/tldev
Directory for temporary files: '/tmp'
Installer directory: '.'
Loading http://gd.tuwien.ac.at/publishing/tex/CTAN/systems/texlive/tlnet/tldev/tlpkg/texlive.tlpdb
couldn't connect to display ":0" at
/Library/Perl/5.8.6/darwin-thread-multi-2level/Tk/MainWindow.pm line
Tk::MainWindow->new() at tlpkg/installer/install-menu-perltk.pl line 233

OK, it's my fault, but can someone maybe add a note "you need to run
X11 in order to be able to use x11"? (Minor, unimportant issue, but it
would be nice to document it somewhere.)

OK, let's "startx".

Surprise, surprise! It works, but I get approximately 800 x 100
window. I didn't really measure it, but it used to work before Taco
started complaining about too big size. Norbert?

I'm now running a fresh network installation, I hope it will work.


More information about the tex-live mailing list