[tex-live] trouble starting context on latest tl2008 developer snapshot

Jesse Alama alama at stanford.edu
Mon Jul 7 20:37:47 CEST 2008

Hi Taco,

Taco Hoekwater <taco at elvenkind.com> writes:

> Norbert Preining wrote:
>> On Mo, 07 Jul 2008, Taco Hoekwater wrote:
>>> I will sort this out and report back.
> I had somewhat different results here, but indeed it took a little
> bit of effort to get context + luatex running. I fear someone else
> will have to fix the installer, I don't know where to look / what to
> do, sorry. There is not much to be done, afaics.
> A step-by-step account:
> I ran the networked installer in a virtual box running suse 11, and
> initially, my virtual box screen size was 800x600. That does not
> combine with the -gui option of install-tl: the Tk window simply
> doesn't display the bottom part of the installation screen.
> This was not a big problem, I just made the vbox larger and I doubt
> people with real hardware have such tiny screens these days. I also
> understand that such small displays are not supported, but still:
> maybe it would be better to give a message and abort or fall back
> to the non-gui version instead of drawing a useless window?
> I first installed the 'texlive scheme for context', and later a 'texlive
> full' as well. In both cases, the download and installation went fine,
> no problems at all. It looks like the 'context' scheme installs a fair
> number of packages that are not actually needed by context users, but
> that is mostly cosmetics (it is not that much in actual bytes, and I
> only noticed because I know rather precisely how much should be enough).
> After installation was complete, I had to fiddle a bit to get the
> binaries included in the path, I am not sure whether that is supposed
> to be handled by the installer or not?
> In any case, after adjusting $PATH
>   texexec test
> and
>   texexec --xtx test
> both ran out of the box, excellent! This is already better than ever.
> (test.tex is just a small test file I created on the spot, 'hello
> world'-ish)
> However, context+luatex did not run. The problem was that the
> installation does not create the link for "mtxrun" in the binaries
> directory, so I had to do that manually. It did create the other
> two script links ("context" and "luatools"), only "mtxrun" was missing.
> But "context" is a shell wrapper that runs "mtxrun -script context",
> so the "context" command was broken as well.  I just copied "luatools"
> to "mtxrun" and edited it to change luatools.lua into mtxrun.lua, that
> was good enough.
> There is a bit of post-install work that is needed for context+luatex
> that is not done by the installer, I ran those two commands by hand:
> First
>   luatools --generate
> (this sets up the texmf cache)
> Second
>   context --make --compile cont-en
> (this creates the format inside said cache)
> after that, "context test" ran ok. No need to change anything in
> the texmf.cnf or set up any environment variable whatsoever, just
> those two commands.
> Jesse, can you please try my recipe to make sure I got it right?

Thanks so much for investigating this.  I will try out your receipe as
soon as possible (for now I am blocked from reporting back because the
latest version of the install-tl script seems to be busted).

Thanks again,


Jesse Alama (alama at stanford.edu)

More information about the tex-live mailing list