[tex-live] Win32 Testing reports

Norbert Preining preining at logic.at
Wed Jan 17 14:16:45 CET 2007

Hi all!

Ok, I did:
- svn sync of texlive, ie getting Functions.pm
- build a new iso with MakeImage
- removed the complete installation of TL2007
- reinstalled TeX Live from the new iso image
- installed latexextra, fontsextra, and some other things


On Die, 16 Jan 2007, Norbert Preining wrote:
> - running pdflatex I get thousands of warnings a la:
>   pdfTeX warning: pdflatex.exe (file c:/TeXLive2007/texmf-var/fonts/map/pdftex/updmap/pdftex.map): ambiguous entry for `ecso1000': font file present but not included, will be treated as font file not present
>   See below ...
> - another strange warning I got with one of my files is:
>   pdfTeX warning: pdflatex.exe: font `cm-super-t1' is not a standard font; I suppose it is available to your PDF viewer then
>   and the respective font is missing in Acroread.
>   But note that cm-super IS installed!
>   Calling updmap by hand fixed this AND the above, but I thought that
>   this is done automatically?

This problem is gone, I didn't have to call updmap.

But, opening a file which uses nothing special but t1/fontenc (so it
should get cm-super fonts) the dvi viewer creates pk files.

No idea whether this is intended.


> - What remains after calling updmap are warnings:
>   pdfTeX warning: pdflatex.exe (file c:/TeXLive2007/texmf-var/fonts/map/pdftex/updmap/pdftex.map): invalid entry for `gsxu1000': both ps_name and font file missing
>   Several of these ... 

Still here


> - texexec does not do anything. However I call it, it returns without
>   any trace of output etc.

Ok, as mentioned, I installed ruby: I downloaded ruby 1.8 (whatever),
started the installer which put everything into c:\ruby.

After a reboot texexec is working. I didn't have any files for checking
at hand.


> - pdfcrop does not work
>   Can't locate File/Spec/Functions.pm in @INC (@INC contains: c:\TeXLive2007\perltl\lib ........

On Mit, 17 Jan 2007, Staszek Wawrykiewicz wrote:
> Thanks to Pawel Jackowski I've just added missing Functions.pm (#3536)
> and pdfcrop works now well.

Strange enough, I can NOT confirm this. I get the same error. I checked 
and the file is still not included. So something is still missing ...


One more thing which I found interesting:
dvi viewer shows the followng warning on one test file:
Unknown special:! /pgfH{/pgfheight exch def 0.75 setlinewidth [] 0
setdash /pgfshade {pgfA} def /pgfdir { dup 0 moveto dup 5 index lineto }
bind def} bind def


Ok, that's it for today ...

Best wishes


Dr. Norbert Preining <preining at logic.at>                    Università di Siena
Debian Developer <preining at debian.org>                         Debian TeX Group
gpg DSA: 0x09C5B094      fp: 14DF 2E6C 0307 BE6D AD76  A9C0 D2BF 4AA3 09C5 B094
A form of particularly long sparse sideburns which are part of the
mandatory uniform of British Rail guards.
			--- Douglas Adams, The Meaning of Liff

More information about the tex-live mailing list