[tex-live] Re: LyXWin137preSmall-0-6.exe and TeXLive2005

Stephen Harris techmech at sbcglobal.net
Sat Jan 21 15:56:35 CET 2006


I installed the Win32 distribution but couldn't get it to work because
lack of expertise. I didn't know how to enable the "extra" directories
and then sample.tex didn't work out of the box like it does with Miktex.
Dan Luecking who likes the fpTeX-like functionality was kind enough
to explain how he fixed a few problems. I am reinstalling Win32 now,
and have decided to give it a whirl since there have been some pointers.
Originally, I didn't think this was a suitable distribution for Win users
who are new to both (La)Tex and WinLyX, now officially supported.
I suppose this group of newish users would be better off with ProText.
The new installer works really well!


Dan Luecking wrote:

"What TeXLive2005 _appears_ to have done, is take xemtex and
add the missing programs, but recompiled and/or relinked to the
new DLLs when necessary.

I found it worked out-of-the-box for my mode of use on one
computer, but required editing modes.mf (changing localfont
from ljfour to jetiiisi on the other).

Three small problems:
1. the intallation program allowed some customization. When I chose
one of these a dialogue window popped up. But every time the mouse
cursor strayed over the main window, it (the main window) rose to the
top, covering the dialogue. This started out confusing (the dialogue
seemed to have disappeared), then became merely annoying when I
figured out what was happening.

2. One can select any of several schemes to install. To be on the safe
side I installed more than I needed and tried to delete things I
didn't need. To my suprise, most of the texmf-dist and texmf-doc trees
were read-only. This was an annoyance, especially for some
configuration files that needed to be edited (modes.mf, for example).

3. A third problem just surfaced, involving updmap. I tested and found
that the previous (2004) version of TeXLive had the same problem (2003
did not, but it had a different problem).

The problem is in updmap and the dvipdfm_ndl14.map it produces.

Dvipdfm requires a .pfb _file_name when a font is embedded, and seems
to require a _font_name when the font is not embedded. The
dvipdfm_ndl14.map that updmap produces fails to include either a
filename (correct) or a fontname (incorrect). When
dvipdfmDownloadBase14 = false in updmap.cfg, dvipdfm.map is equal to
dvipdfm_ndl14.map. With the fontnames omitted, dvipdfm tries to call
gsftopk and embed a type3 font.

The solution is to always embed all fonts (make sure
dvipdfmDownloadBase14 = true in updmap.cfg).

>SH wrote: I use sample.tex (c:\texmf\doc\dvipdfm\sample.tex) to
>test functionality, as this file is intended for that purpose.
>Win32 (xemtex variant) fails to display the graphics included
>in sample.tex.

Dan Luecking replied:

"The (dvipdfm problem) never hit me because I always convert eps
to pdf manually, using tools that produce PDF version 1.3 or less.

The eps to pdf conversion does fail out of the box, but that seems to
be because dvipdfm can't take PDF higher than version 1.3. One needs
to change the config file so that the eps to pdf conversion process
(the line beginning with D) produces version 1.3 or lower. I use
  D "epstopdf --outfile=%o --nocompress %i"
in config and edit epstopdf.pl (which produces 1.4 by default on my
system). Instead of editing epstopdf.pl, one could
  set GS_OPTIONS=-dCompatibilityLevel=1.2
on the command line or use a gs command in config that sets the level:
  D "gswin32c.exe -q -sPAPERSIZE=letter -sDEVICE=pdfwrite
-dCompatibilityLevel=1.2 -dUseFlateCompression=true -dNOPAUSE
-sOutputFile=%o %i -c quit"
(all on one line). Problems can occur "out of the box" because the
out-of-the-box config file has incorrect quoting for windows. The
config-win provided (copy it to config) uses epstopdf. Using dvipdfm's
-vv option quickly showed me where the problem lied (in the pdf
version produced by epstopdf).

I remove quoting around the file names (%o and %i) in config's D
option, and never use filenames or paths with spaces in them.

Miktex's dvipdfm used to get this wrong consistently also.

Hope this helps those out there who have problems with this.

I never use dvipdfm without manually producing pdf from eps where
necessary (using tools that get the PDF version right)."

Stephen Harris

More information about the tex-live mailing list