[tex-live] TL 2003 on RH 7.3 (fwd)

Lars Madsen daleif at imf.au.dk
Wed Jul 21 15:02:50 CEST 2004

Forwarded answer:

> On Freitag, 16. Juli 2004 13:45, Lars Madsen wrote:
>> A friend of mine tried to install TL 2003 on her RH 7.3 but it failed with
>> an error like this
>> Error: `etex -ini  -jobname=latex -progname=latex *latex.ini' failed
>> etc.
>> any idea what happens here, it install without problems om our RH 7.2
>> system.
> Hello,
> since I have not yet seen any answer to your question, I give it a try.
> My guess would be, that the problem already occured somewhere before.
> Did your friend already have a TeX installation before? Where did she install
> the distribution?

Yes I have tetex-1.0.7 installed in /usr/share/texmf and /usr/bin is
included in my path. I have two directories where I have write access
without being root: /usr/users/vivip (=HOME) which is nfs-mounted and
where I have a local texmf-tree where I have installed some packages
which I where missing. The other is /home/vivip which is on my local
machine and I tried to install in /home/vivip/usr/TeX.

> I encountered some problems, when I installed it on a FAT
> partition. Did she update all involved environment variables, especially PATH
> and TEXMF and friends?

No, I tried to follow section 3.2 in the documentation and it said I
should update PATH after I had run "sh install-tl.sh", but that gave
me the above errors. I don't have any environment variables named
something with TEX (after I deleted TEXINPUTS). Maybe this is what I
did wrong?

> What gives
> which latex

Before I tried to install it gave /usr/bin/latex (should I have
removed /usr/bin from my PATH while I installed Tex-Live?)

> which kpsewhich
> kpsewhich texmf.cnf
> She could also try
> texconfig confall
> after she made sure, that the environment variables are set correctly.
> Alois

I tried installing tetex-2.0.2 instead and that works, so now I'm using
that, but thanks for your answer.

>> TEXMFINPUT(S) has been set to a local directory, can this influence
>> anything??
> Are you sure, that there is some variable like that? I know TEXINPUTS, TEXMF,
> TEXMFCNF and so on.
> If she sets TEXINPUTS, she should also take care, that the default directories
> are included; usually that is accomplished by an empty entry, eg. by a ":" at
> the end or by "::" in the interior of the variable (of course, also by ":" at
> the start).

Sorry, I remembered wrong. The one that was set was TEXINPUTS ~/texmf//:
I deleted it and tried to install again, but it gave the same errors.



More information about the tex-live mailing list