[tex-k] note from Prof Knuth

Maggie (not) McLoughlin mam at theory.Stanford.EDU
Wed Oct 25 01:46:39 CEST 2006

Dear tex-k-ers,

For the last couple of weeks, the kpathsea programs on my Linux
machine at Stanford have generated a new format file every time
I run tex or mf or whatever. For example, I get responses like

  This is TeX, Version 3.141592 (Web2C 7.5.4)
  kpathsea: Running mktexfmt tex.fmt
  fmtutil: running `tex -ini   -jobname=tex -progname=tex -translate-file=cp227.tcx tex.ini' ...
  This is TeX, Version 3.141592 (Web2C 7.5.4) (INITEX)
  (/usr/share/texmf/tex/plain/base/plain.tex Preloading the plain format: codes,
  Hyphenation trie of length 6075 has 181 ops out of 35111
    181 for language 0
  No pages of output.
  Transcript written on tex.log.
  fmtutil: /home/uno/.texmf-var/web2c/tex.fmt installed.
  This is MetaPost, Version 0.641 (Web2C 7.5.4)
  kpathsea: Running mktexfmt mpost.mem
  fmtutil: running `mpost -ini   -jobname=mpost -progname=mpost -translate-file=cp227.tcx mpost.mp' ...
  This is MetaPost, Version 0.641 (Web2C 7.5.4) (INIMP)
  Preloading the plain mem file, version 0.64) ) )
  Beginning to dump on file mpost.mem
   (mem=mpost 2006.10.24)
  at most 1430 strings of total length 23626
  3296 memory locations dumped; current usage is 977&2225
  477 symbolic tokens
  Transcript written on mpost.log.
  fmtutil: /home/uno/.texmf-var/web2c/mpost.mem installed.

My home directory is /home/uno. Directory /home/uno/.texmf-var/web2c 
currently contains mf.base, mf.log, mpost.log, mpost.mem, tex.fmt,
and tex.log, all created today. If I run TeX again, it will
create tex.fmt again.

Evidently the system isn't able to find the formats it has generated,
but this behavior is new; everything used to work fine.

So I suppose the system administrator has done something to my
computer, changing protections in some way. But I have no idea
what to tell him, and of course he has no clue about why such
a big system as TeX is suddenly failing.

Please tell me how to diagnose the problem so that I can
tell him what needs to be fixed.

Yours truly, Don Knuth

P.S. There's a file /var/lib/texmf/ls-R that hasn't changed since
August. A few days ago I saw a message that one of the programs
wasn't able to write on it. We changed protections of /var/lib/texmf
yesterday, to
    drwxrwxrwt   4 root root    4096 Aug 14 16:16 texmf
but that directory still contains just three files
  -rw-r--r--   1 root root 3437 Aug 14 16:16 ls-R
  drwxrwxrwt   7 uno  man  4096 May  6  2005 tfm
  drwxrwxrwt   5 uno  man  4096 Apr  2  2005 pk
I haven't been able to reproduce the error message about
not being able to write on /var/lib/texmf/ls-R. But anyway
that file (from last August) only has pk's, not fmt's or base's or mem's,
so it probably is irrelevant to the problem I'm having.
On the other hand, when kpathsea generates new fonts,
the new fonts are remembered; so there is SOME ls-R file that
is getting updated properly somewhere.

More information about the tex-k mailing list