[pstricks] PSTricks Digest, Vol 140, Issue 5

Donut E. Knot the.counterterrorist at yahoo.com
Fri Sep 5 05:46:19 CEST 2014

Responding to the bug reported by Hubert Lam.

I can reproduce the bug. I also notice that it can be fixed by swapping the order of loaded packages, i.e., \usepackage{pst-func,pst-eucl} instead of \usepackage{pst-eucl,pst-func}. It seems to me `\pst-func` overrides settings defined in pst-eucl.

best regards,


On Thursday, September 4, 2014 7:41 PM, "pstricks-request at tug.org" <pstricks-request at tug.org> wrote:

Send PSTricks mailing list submissions to
    pstricks at tug.org

To subscribe or unsubscribe via the World Wide Web, visit
or, via email, send a message with subject or body 'help' to
    pstricks-request at tug.org

You can reach the person managing the list at
    pstricks-owner at tug.org

When replying, please edit your Subject line so it is more specific
than "Re: Contents of PSTricks digest..."

Today's Topics:

   1. Re: auto-pst-pdf with beamer (Doris Behrendt)
   2. pst-func & pst-eucl bug (Hubert Lam)


Message: 1
Date: Thu, 4 Sep 2014 12:37:01 +0200
From: Doris Behrendt <doris.behrendt at me.com>
To: Graphics with PSTricks <pstricks at tug.org>
Subject: Re: [pstricks] auto-pst-pdf with beamer
Message-ID: <0ABD3B95-18CE-48BC-89EC-0EF8A0A63E3B at me.com>
Content-Type: text/plain; charset="windows-1252"

Hi Herbert and others,

thanx, your code worked, BUT ?

in the meantime I have tried some other files (different package cominations, but always beamer with auto-pst-pdf) and tested some minimal examples.

In most cases, the pdf is produced, but the pstricks-pictures are not included; I get the following message, which I don?t understand:

[1] [2] [1] [2] [3] [3] [4] [4] [5] [6] [5] 
Error: /typecheck in --div--
Operand stack:
   1   0   0.0   0.0   a   65781.8
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1900   1   3   %oparray_pop   1899   1   3   %oparray_pop   1883   1   3   %oparray_pop   1771   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   --nostringval--   4   --nostringval--   %repeat_continue   --nostringval--
Dictionary stack:
   --dict:1169/1684(ro)(G)--   --dict:0/20(G)--   --dict:174/200(L)--   --dict:203/300(L)--
Current allocation mode is local
Last OS error: Invalid argument
Current file position is 370634
GPL Ghostscript 9.10: Unrecoverable error, exit code 1
PDFCROP 1.38, 2012/11/02 - Copyright (c) 2002-2012 by Heiko Oberdiek.

!!! Warning: Empty Bounding Box is returned by Ghostscript!
!!!   Page 1: 0 0 0 0
!!! Either there is a problem with the page or with Ghostscript.
!!! Recovery is tried by embedding the page in its original size.

==> 1 page written on `links-rechts-vgl-pics.pdf'.
auto-pst-pdf: End auxiliary LaTeX compilation

????????????????????????????????????end of console snippet

I also tried older versions of texlive (2012) and there everything seems to work fine (I?m just testing)
I tried 2014 on mac(maxtex) and pc(texlive, windows 8) and on both systems I get the same error message quoted above; 

what can I do to get beamer and auto-pst-pdf ?


On 03 Sep 2014, at 19:02, Herbert Voss <Herbert.Voss at FU-Berlin.DE> wrote:

> Am 03.09.2014 18:27, schrieb Doris Behrendt:
>> please have a look at this; I guess it has to do with the rotating package? below after the minimal example I have pasted also the console output;
>> \documentclass{beamer}
>> \usepackage{etex}
>> \usepackage{auto-pst-pdf}
>> \makeatletter
>>     \let\Test at pr@shipout\pr at shipout%% save the original definition
>>     \let\Test at shipout\shipout
>>     \makeatother
>>     \usepackage{tikz}
>>     \makeatletter
>>     \AtBeginDocument{%
>>      \let\pr at shipout\Test at pr@shipout%% restore it 
>>      \let\shipout\Test at shipout
>>     }
>> \makeatother
>> \usepackage{pstricks}
>> \usepackage{%
>> pst-3dplot,<????????comment this out and it works!
>> }
>> \usepackage{tikz}
>> \usepackage{rotating}
> use
> [...]
> \makeatother
> \ifpdf\else
>  \usepackage{pstricks}
>  \usepackage{pst-3dplot}
> \fi
> \usepackage{tikz}
> \usepackage{rotating}
> [...]
> Herbert
> _______________________________________________
> PSTricks mailing list
> PSTricks at tug.org
> http://tug.org/mailman/listinfo/pstricks
> archive: http://www.tug.org/pipermail/pstricks/


Message: 2
Date: Thu, 4 Sep 2014 12:36:50 +0000
From: Hubert Lam <hubert at lamfamily.info>
To: Graphics with PSTricks <pstricks at tug.org>
Subject: [pstricks] pst-func & pst-eucl bug
    <241365cec0e14ad580a3200ace5f6591 at HKNPR03MB132.apcprd03.prod.outlook.com>
Content-Type: text/plain; charset="us-ascii"

Hi all

Has this been reported before?

If you load pst-func as well as pst-eucl, and try to create nodes, the PointName for the nodes (from pst-eucl) will default to a silly looking "I":

[cid:image001.png at 01CFC890.2A1C0940]

If you load only pst-eucl, the correct PointName (s) appear:

[cid:image002.png at 01CFC890.2A1C0940]

Minimal example:


%\usepackage{pst-eucl,pst-func} % use as appropriate to test


I am using pst-func dated 26/5/2014 and pst-eucl dated 20/5/2014 (both via MiKTeX).


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/pstricks/attachments/20140904/bd17f9ba/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.png
Type: image/png
Size: 7684 bytes
Desc: image001.png
URL: <http://tug.org/pipermail/pstricks/attachments/20140904/bd17f9ba/attachment.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image002.png
Type: image/png
Size: 7737 bytes
Desc: image002.png
URL: <http://tug.org/pipermail/pstricks/attachments/20140904/bd17f9ba/attachment-0001.png>


Subject: Digest Footer

PSTricks mailing list
PSTricks at tug.org


End of PSTricks Digest, Vol 140, Issue 5
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/pstricks/attachments/20140904/868238cc/attachment-0001.html>

More information about the PSTricks mailing list